Google Assistant - trouble with syncing

Hello everyone…

I need help, i have gone through all the steps in this guide:

I link the account in my google home app on the phone and it seems to work fine ( i log in on the hassio screen appearing).

But when i tell google home to sync it tells me:

“An error occured when syncing my test app”

Any thoughts?


1 Like

you went all the way and setup the homegraph and added the api to the config?

Hi David,

Yes, so i have repeated the process numerous times and set up several projects.
Each time i can “add” the test app in the Home app and with my iphone it seems to link the account or at least says so.

However when i ask the Google home mini to “sync my devices” it says “it looks like you dont have any devices supporting syncing”

Im clueless as of now

I find every so often I lose this ability and have to remove and re-add the app through the Google Assistant app, but only after I run the draft Test each time. Quite annoying…

1 Like

It’s the price you pay for the free integration. Google disables the test app from time-to-time. I usually only need to re-enable testing and it works again without relinking.


Ahh I see, thanks for elaborating.

Had a similar problem and found this topic just before posting a question. In the end I got it solved by unlinking and linking again… Here was the text I was going to post, just for reference as it might help others find this topic.

I added some new device to my home assistant setup and wanted to do a “reload devices” on the google assistant to be able to use the google home to voice-command my setup. Previously that always worked and when I give commands to google home for the “old” devices, everything works fine.
When I enter “reload devices” in the google assistant chat I always get the response “Sorry, an error occurred while syncing mr. Pippin”. Any idea why that stopped working?

So, the solution as proposed by @DavidFW1960 and @talondnb works!