Google Assistant TTS with Duckdns

I’m using the Duckdns addon for remote access to my HASS VM, and so that I can use my Google Homes to control switches, etc - which works great.

I’m also trying to use the Google Homes to feed back on automation, using the Google translate tts component. When the tts action triggers, the Google Homes turn on, and each play the ‘on’ sound, but no speech plays.

My config currently looks like this:

  - platform: google_translate
    service_name: google_say
    base_url: "<local HASS IP>"

I’ve also tried the external duckdns hostname as the base URL, with “http://”, as well as with the port (8123) but to no avail. Here it mentions using the local IP so that it doesn’t resolve DNS, but this doesn’t seem to work either.

Is this not working because of my duckdns config for using this: ?

I’ve also tried setting the Google Homes DNS to OpenDNS (using my PFSense firewall), bypassing Google’s DNS as also mentioned on that link above.

Is there anything I can do to make this work? Thanks for any help!