Google assistant works and Google Home doesn't with cloud by nabu casa

I am new and I have my HA OS pretty well working on a VM with ESXI 6.5.

I activated the cloud services by Nabu Casa to get Google assistant working (couldn’t get it working with the tutorials without cloud by Nabu Casa.

And when I ask something to my google home device I get a response of something like:" Cannot reach home assistant with cloud by nabu casa".

But when I ask the same thing to my google assistant on my phone (android pixel 3) I get a working respons.

I already disabled ipv6 on the VM.

I have a G-suite google account.

I tried a lot, but I don’t get it.



Hi Niels

If you look in HA under Cloud integration, does it say ‘connected’ under nabu-casa account?
And looking under Google Assistant, it’s activated and you have the entities syncronized, and you can see them in the Google Home App on the phone IN THE RIGHT HOME, right?

You can have multiple home’s in Google, and if the home devices are in one home, and the ha devices on another, it could cause problems.
Not sure about a g-suite account, never tried that with HA.

Hi Fribse,

Thanks for your reply.

Cloud is “Connected”

Google Assistent is “activated”

I have my entities synchronized (selected a couple and re-linked the account of nabu casa again so they would be updated)

I used to have 2 homes, but I deleted one a couple of weeks ago.

And it works on my phone very well. But my google home refuses to connect to nabu casa and home assistant.

@fribse I know what the problem was. The Google Home is indeed another “home”. Account of my girlfriend is the main account of the “Home” . This is due to the fact that G-suite accounts are not full Google accounts (we pay for them, but we can’t do all a regular free google-account can) My Nest Hello for example cannot be linked to a G-suite account. But that’s why it is not working for me.

Thanks all

1 Like