Google Assistant works, but says "I cannot reach my test app"

Hey Everyone,

I was just curious if anyone knows how to troubleshoot this issue. I have configured the google assistant integration, as well as device sync for home assistant according to the documentation in the HA wiki. I use an nginx reverse proxy to expose HA to the internet with an SSL certificate. Sometimes (about 20% of the time) when I issue a command to my google home device like “turn off the bedroom TV”, it will perform the action successfully (bedroom TV will turn off) but then the google home will say, sorry I couldn’t reach my test app.

I have looked on the google actions console for any sort of logging I can find that would help me better narrow down the problem, but I cannot seem to find any logging from voice commands to HA.

Any help in narrowing this down would be greatly appreciated.

Does anyone else use Hass behind an NginX proxy?

I’ve got the same issue… Usually only happens if I haven’t issued a command in a while from Google home to HA.

Hi, I have the same issue. Google assistant integration works fine, but sometimes after a command GA says “sorry, cannot reach app”.
I do not have a reverse proxy. Any clues will be appreciated.

Oh god - I get this all the bloody time… It drives me nuts… I haven’t been able to control my lights all night…

same problem here. intergration works but GA says sorry cannot reach myapp. I dont have a proxy.

Same. Happens every now and then

I have the same issue. Worked at first but no more.

THIS IS A WARNING on the HA forum

To use Google Assistant, your Home Assistant configuration has to be externally accessible with a hostname and SSL certificate. If you haven’t already configured that, you should do so before continuing. If you make DNS changes to accomplish this, please ensure you have allowed up to the full 48 hours for DNS changes to propagate, otherwise Google may not be able to reach your server.

I don´t get it. Can someone please explain where can we allow 48 hours for dns changes to propagate? Thanks in advance

Starting over worked for me