Google Assistnat manual integration stopped working since 2023.1.0?

Looks like the Google Assistant integration stopped working since I upgraded to 2023.1.0.
I originally thought there is an issue with the configuration on the Google Action so I did all the steps over again.
Then I moved from DuckDNS to Cloudflare to eliminate this issue as well.
I cant get the Home Assistant action to be connected with Google home, error:
Couldn't reach [name of action] please try again later
I’ve found a few reddit posts about this but no solution so far:

Is it something on Google’s side?

Just came here to +1 this. Everything worked fine until 2023.1.0 . Repeated the entire manual setup guide with the same results ( Google Assistant - Home Assistant ).

Same Issue for me. Google Assistant integration (free - not nabu-casa) stop working and synching.
I check many posts. I read-did entirely the step by step configuration. Nothing worked. I saw a post from a user living in sweden. mentioned he connected via vpn to the USA, and it worked again.

so I connected my phone to the US via VPN, opened Google Home App, added my “[test] Hassio” and voila it worked, it synched again.
issue maybe DNS or country related.

just to clarify. all of my Google Project stay the same.
I only had to VPN connect my phone to the US (one time only)
then in Google Home App select my [Test] Hassio
input my HomeAssistant User/Password
Then it synched.

After this synch / refresh, google home app works fine without vpn.
But for any further device sync / add devices. VPN to US is needed.