Google calendar is not working for me

i’ve setup the google calendar in HA, it worked for a while and then stopped.
it fails to create the calendar sensors.
from the log:
[homeassistant.components.calendar] Timed out adding entities for domain calendar with platform google after 500s
and that’s it.

i’ve tried to recreate the credentials, deleting it from the configuration.yaml and re-adding it after restart… nothing helps.

any ideas?

Delete the file .google.token, restart HA and confirm credentials again.

I did that already. Didn’t help

Did you get a norification to athenticate with Google again?

Yes. And I did. I even checked the actual API on the Google developer page and it working fine.
I did find this…

Hmm strange. I do remember Google Calendar had an issue like a month or two ago. Which was caused by Google servers. That was fixed in a day or so. This seems to be different, since not many users are having issues. Did you also create an entire new project and use that as credentials?

No, that I haven’t tried yet. I’ll try it tonight.

OK… Creates a new project, added it to HA. Same issue. Timed out adding entities after 500s.
I believe the issues started when the Google servers issue started, and it never came back.

I’m having this exact same issue. Reset everything new credentials, new project, same issue.

Has anyone been able to get around this?

apparently, it was an issue with my router not being able to handle so many devices. I switched to a mess network and since then everything works fine.

Strange. I’m already on a mesh, but having internet issues today. I wonder if that could be doing it.

I think it was because my project in GCP was set to production…set it back to testing and the token was immediately accepted again