Google calendar issue - Authentication code expired, please restart Home-Assistant and try again

Hi

So i followed the instruction to set this up, and have done it before, but i just get this message.

Authentication code expired, please restart Home-Assistant and try again

there is no .token file in my config folder so i dont know how to proceed. Oauth and credentials have been generated.

2021-06-04 10_56_07-Konfigurasjon - Home Assistant

1 Like

some more pictures

Really dont understand what is happening here, deleted all my projects, set up one new, have done it before on other systems, but got a new nuc now.

dont have a token file, but its saying authencation code has expired, why? :expressionless:

2 Likes

same here…

1 Like

Seems more people are having this issue, no answer from the HA team yet

Same here …

I have the same problem. I have tried everything and I have not solved anything …

I also have this problem =/

Same here…

Same problem here! Can’t fix this issue so waiting for an update

I have the same problem :frowning_face:

Having the same issue

Same problem here

You get this as soon as you restart and try the code?
I had an issue getting the code to stick but it was due to a bad copy and paste of the key into the config file. I realize this isn’t what is afflicting everyone else but just wanted to mention it.
After correcting that it took and the Calendar created but I am not getting all my events. Sounds like there may be a few things amuck with the integration.

Yes sir, also got the same issue as the others and followed the instructions several times.
Is there anything more to troubleshoot or more information that we could provide to solve this issue?

I use also Google Cast for some devices, is there maybe already some key exchange happening and my second connection for the calendar broke because of this?

Would love to have a working calendar integration in home assistant :slight_smile:

I think I have the same situation as described.

  • Done the google configuration
  • entered everything in home assistant using !secret
  • reloaded home assistant
  • got the error “Authentication code expired, please restart Home-Assistant and try again”
    • no google_calendars.yaml file was created
    • no .google.token file created

My tries to troubleshoot for the moment were:

  • tried creating the google_calendars.yaml file myself to check for permission errors → haven’t worked so far.
  • tried entering the credentials directly into the configuration.yaml → haven’t worked so far.
  • tried entering the client ID without .apps.googleusercontent.com → haven’t worked so far.

Sorry - I wish I was able to help more.
I’ve read about some issues with values starting with 0. Does either your id or secret start with 0?

Unrelated to your auth issues but I did find that my shared calendar entries are showing on week or day view but not on the month view. Also I don’t see a way to view the details of the entry. Clicking on an entry doesn’t do anything.

I am new to HA but seems like the calendar would be a commonly used integration. Maybe not?

No bad feelings :wink:
None of my values start with 0, so this should also not be the problemo.

I could think that this integration is widely used, let’s see if the devs have a good idea on Github or if there will be an update for this integration that fixes the issue.
Would love to use a calendar integration on my panels.

Workaround was found on GIT:

Worked for me to set timezone for configuration to etc/GMT, after configuration, I reset this to my acual one.
Happy day :slight_smile:

1 Like

Thanks that fixed it for me too

1 Like