Google calendar issue

I moved over to HassIO from Hassbian and copied my old configuration.yaml file across when I did that. However, I was logged in to a different google account at that time and it has associated my google calendar component with that account rather than the one I want it to.

So far I have tried;

  1. Changing the e-mail address in the entity itself, but it reverted back.
  2. Deleting the google calendar component from my configuration.yaml file and deleting the google_calendars.yaml file and restarting home assistant. Then adding the google calendar component back to my configuration.yaml file, making sure I was logged in with the correct google account and restarting home assistant again.

It is still coming up with the wrong google account and not the one I want to use with home assistant. I am thinking the entity needs to be removed and it must need to be deleted from elsewhere (possibly somewhere in the home-assistant_v2 database file)


Did you copy over the file .google.token ? I believe that’s where the authentication token is stored. I imagine that deleting that file will put you back on the right path.


I have looked at the files I backed up before moving to HassIO and .google.token was not one of them, so I couldn’t have had that previously when it worked.

I do have that file now, but I have installed the google assistant addon and it appears to contain data relating to that.

Thanks! this helped me, when i wanted to change the google calendar I was pulling from. did’t see that hiding in the config folder.

Resurrecting an old thread here because I think it may be similar to my issue.

My Google Calendar setup got screwed up somehow (HA stopped seeing my calendars) so I decided to start the whole process over again. I have even deleted my HA project from Google and created a new one, new Google Assistant and Calendar setup. The problem is that HA is still not seeing my calendars and I think its because the Authorisation pop-up never came through as per the last section of the below instructions.

Any ideas what I can do to fix this?

After playing around with the .google.token file and seeing what effect that has I think my issue is that I need to find a way to re-trigger Google to request authorisation from HA again. Is there a way to do this?

Ok, so I worked it out. deleted the .google.token file, went into the Google API Console and re-saved the Oauth consent. Restarted HA and it brought up the Google login request. All good now :grin:


This worked for me for something similar…

This just helped me. Thanks. I was deleting the yaml file, but not the .token file.

Well I seem to have an issue that my google token is being invalidated every 24h orso…any ideas why this could be the case?

1 Like

I recognize these days the same issue. With deleting the token and reauthorization I can fix it, but that’s not acceptable to do every or every second day…

I really like my google calendar integration but I am having the same issue with having to reset the token. Seems that it needs done with increasing frequency.


I can’t even complete the initial configuration, after entering the google credentials, I just got the error:
Authentication code expired, please restart Home-Assistant and try again

Also I can’t find any google_calendars.yaml or .google.token files in my config folder.

I use HA from the virtual machine image, if this makes a difference.

Thank you all and BR

1 Like