Google cards not working anymore

Is it only me ? The Google cards that I am using for location is showing an explanation mark.

Is this because google changed a few things regarding there api’s ?

Are you using this method?

If so mine is still working. Check the location information of your device tracker to insure it includes a lat and lon.

Yes thats the one. I didnt change a thing ( in HA at least )

I think it’s missing an application or library on my Ubuntu server… not sure what

Working fine here. I’m using 2 trackers (me + car) in the same view and I did notice that the whole picture goes blanc if one of the two trackers gives a false location. Usually it’s back in 1 minute or so:image

mmmmm… my laptop is also showing nothing

the url :,xxxxxxxxxx

this is in my config :{{ states.device_tracker.iphonedaniel.attributes.latitude }},{{ states.device_tracker.iphonedaniel.attributes.longitude }}&zoom=13&size=500x500&maptype=roadmap&markers=color:blue%7Clabel:P%7C{{ states.device_tracker.iphonedaniel.attributes.latitude }},{{ states.device_tracker.iphonedaniel.attributes.longitude }}

Then there is probabaly something wrong with your link. Try it in the dev tool and copy the output to your browser to check.

How many times you refresh the location? There is a limit on the Google API (not sure how much).
Do you use the following line in your config?

    limit_refetch_to_url_change: true    

when I paste the output from the dev tool I also got an explanation mark… Yesterday I have added a second device.tracker ( iphone of my gf) but this morning I did found out that the
limit_refetch_to_url_change: true was not in my config for this device. Maybe thats why ? but I thought the limit was 2500 times a day. So no idea if that is te problem.

Ifo so then it should be working tomorrow again…

EDIT: OK thats strange…
looking at :
also shows the explanation mark … I dont get iyt anymore… but its not a HA problem

EDIT 2: Ok, this is very strange… not a HA problem. When I open the url on my phone ( via 4G) then its ok .

EDIT 3: It’s working again! for people with the same issue ( in the future or so :slight_smile: ) this had to do with forgetting the
limit_refetch_to_url_change: true option!