Google Cast drops home assistant cast connection

I am also having this issue. My hub has been reduced to a clock.

Same issue here. My hub is now useless. It’s going in the drawer.

Try this method. Works well for me.


I would encourage to try CATT, it works like a charm. See this thread Using CATT

Unfortunately mine has now started doing the 10 minutes and timout issue regardless of if I select the cast manually. The GoogleHome received another update perhaps I was one update behind. Not largely useless to me again :frowning:

Just stumbled upon this thread when deciding whether or not to buy a GA hub for a HA dashboard. From reading this thread and your post it seems like there is a 10 minute timeout regardless of whether or not you cast from the HA Google Cast integration or from CATT, but with CATT you can re-cast as it will wake the device from ambient mode. Is this correct?
CATT actually uses the pychromecast library which itself is from HA ( It looks like CATT uses dashcast for loading web pages ( and sets the force parameter to True ( when sending a message. HA cast doesn’t specify the force parameter and the default force parameter for a message is False ( That might explain the difference in how the hub wakes up from ambient mode.

That would make sense.
Would be great if HA cast could have an option to force it!

Whilst having to refresh every 10 mins is annoying, using catt has actually solved a few problems i had around custom cards and content not always displaying, so thats a bit a silver lining

To archieve this with CATT is to difficult for people with low programming experience.
Indeed i hope HA cast i going to have the “force” option for every 10 minutes!

I am using Hassio on a PI4 and can’t get catt to work properly…

Its dead simple. I have next to 0 programming experience and got it working just fine.

1. Install/switch to the community SSH addon (GitHub - hassio-addons/addon-ssh: Advanced SSH & Web Terminal - Home Assistant Community Add-ons)

2. Add the following to the bottom of the add-on configuration

  - python3 -m pip install catt 

3. add an automation to cast using CATT every ten minutes. The first and 3rd actions are options but avoid hearing the cast sound every ten minutes. Instead you hear the volume change which is a more subtle sound.

Adjust “Family Room Display” to match your google home hub and double check your add-on name. (its at the end of the URL when you visit the add-on page)

  - alias: CastToHub
      platform: time_pattern
      minutes: /10
      - service: hassio.addon_stdin
          addon: a0d7b954_ssh
          input: catt -d "Family Room Display" volume 0
      - delay: 00:00:05
      - service: hassio.addon_stdin
          addon: a0d7b954_ssh
          input: catt -d "Family Room Display" cast_site
      - delay: 00:00:10
      - service: hassio.addon_stdin
          addon: a0d7b954_ssh
          input: catt -d "Family Room Display" volume 75

Thanks for the info, was doint wrong things!
It’s working now :slight_smile:

Hi, I’m trying to cast with CATT, works fine when I’m using the SSH terminal, my dashboard is caste but I can’t automate it with the hassio.stdin service, the addon log return an error as below
Is someone have an idea on what is going wrong ?

Auto reply, set the ‘share_sessions’ parameter to ‘false’

1 Like

Had this issue too. As you mentioned, change the SSH configuration to share_sessions: false and it’ll receive and run the hassio.stdin correctly

In the meantime I have created an automation that works with the integrated cast and re-casts a view every 9 min if the hub is not playing anything else: Cast and re-cast a lovelace view to a Google Hub

1 Like

Has anyone installed catt on a Rpi4 hassio? Is it possible?