Google Cast drops home assistant cast connection

I have a Unifi network, a Google Nest hub and https://cast.home-assistant.io/ on the google Nest device.

Since 2 days I have the strange issue that the Google Nest hub after 10 minutes the connection drops on the screen and the https://cast.home-assistant.io/ still thinks, tells me that it is casting.
I checked the log on the Unifi Controller for the hub, no package lost, the connection stays good.

Rebooted home assistant, Google Nest hub and reconnected several times cast home assistant, but every time after 10 minutes the screen casted is dropped.
Hope to hear from someone.

I too am having this same issue.

I woke up this morning and noticed my Nest Hub was rebooting so i’m maybe guessing that there was an update to the Nest Hub and its broken the Home Assistant Cast connection… which i know was expected but is such a shame if it’s actually the case!

Hello, I also now noticed the Google Nest hub has a new update installed. For example I noticed the timer from the Google hub is complete different than before. First a circle that counts down, now a square that counts down on the edge of the hub.

Did install the 0.110.0 version as of 21-05-2020. That didn’t do the trick.

So the big question is, did the Google update corrupted the cast ability for cast.homeassistant.io? Have not find an answer yet.

Same issue here.
Thought it’s connection problem but verified on two different wifi networks and problem still exist.
Nest hub firmware 203796 / Cast 1.46.203796.

@michal.mydlarz I can confirm I have the same Cast firmware.

I also doubted first that the issue was my WiFi network. Hopefully we can hear more users with this issue so they might look to a solution.
Odd things is that it works for the first 10 minutes and the cast website keeps telling me the cash is alive.

Other observation: changing view using cast.home-assistant.io prologue this 10min timeout.
I’ve tried to do a hack with automation and change view every 5min but doesn’t work - after 10min it’s gone :confused:

Ah good to hear you tried something else. Too bad even the automation did not do the trick.

I was hoping a ton of users would respond. Hopefully soon more.
It started for me Saturday 16th of May. I guess the Google Hub update was in that timeframe somewhere.

Looks like this bug is in nest hub firmware:
https://support.google.com/googlenest/thread/45388769?hl=en

That’s interesting, glad others have similar issues with other software casting. Let’s see what will come from it.
Will look for downgrading the firmware.

I did a factory reset, twice, but no success.

Will be continued

Same issue here. Tried multiple hubs and they all have the same issue.

I’m having this issue as well. I hope there is a fix soon.

Its definitely related to the google update.

The only workaround ive been able to find is to use catt instead of Home Assistant CAST.


Using that, the Custom Header plugin, and authorized networks, i can get a similar result to using HA cast.

Catt seems to wake the hub up from ambient mode, whereas ha cast does not.

I have cron scheduled on my NUC every 10 minutes that runs catt. Whilst not idea, its better than the 4 presses it takes to bring the cast content back to the front of screen.

1 Like

Thanks @sh00t2kill too bad Google closes in these kind of updates the possibilities for others.
I do hope one of devs can find a solution

Ahhh, to bad i bought the home hub.
This was the only thing i did with it, cast HA to the screen.
A tablet with wallmount was a way better solution.

Could know that this would happen…

Sure, but I can not find a thing from the devs who do confirm it’s Google that causes this issue with the home hub. I have the hub for the exact same reason.

If you can solve the issue with CATT, I guess something similar can be build into HASS Cast I would imagine.

Hi, I have same issue. Found a solution that seems to be working for me. After sending the cast and waiting for to time out after 10 minutes, on the Google Hub swipe down from the top select Media and the Home assistant cast should be listed there. Select the cast and then it should stay up and not disappear after 10 minutes. Not as clean as it used to be and needs a manual poke on the Hub, but its something. Was worried I was going to have to shelve my GoogHub since I have no other use for it.

After ending a cast and restarting it didn’t timeout after 10 minutes. I haven’t done a lot of testing so I’d be intrested to hear if this works for other people.

Hi, the same for me with a lenovo smartscreen…

Sorry no luck for me. I can select it again but after 10 min its gone again…