Google Cast - problem with internal url

Hi,

Sorry of this has been asked a thousand times before.
I have Nabu Casa so have a working external url.
I’m trying to get Google Cast to work with a Google Home Display. I keep getting errors because for some reason HA is not sending my external url. See here:

Logger: homeassistant.components.cast.media_player
Source: components/cast/media_player.py:387 
Integration: Google Cast (documentation, issues) 
First occurred: 21:27:25 (1 occurrences) 
Last logged: 21:27:25

Failed to cast media http://homeassistant.local:8123/api/camera_proxy_stream/camera.front_door?authSig=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpc3MiOiI5ZjM0NWYxOWQxNDk0ZmQ0YTA0ZDJlNWM0M2JmYjFiYyIsInBhdGgiOiIvYXBpL2NhbWVyYV9wcm94eV9zdHJlYW0vY2FtZXJhLmZyb250X2Rvb3IiLCJpYXQiOjE2NDcwMzQwNDIsImV4cCI6MTY0NzEyMDQ0Mn0.a5-BBsHnGRjPrl0WeNHqA2x_4Mt1UHL2oTuYsLQo57k from internal_url (http://homeassistant.local:8123). Please make sure the URL is: Reachable from the cast device and either a publicly resolvable hostname or an IP address'

It doesn’t matter what I try, I get the same error. Any help would be very gratefully received!

Thanks,
Andrew.

VLAN involved?

Hmmm. I’m running in a virtual box on an intel nuc so there may be network shenanigans due to the bridged connection. But, everything else is fine. I don’t know how I can make the integration pass my external url to the Google display instead of my internal one. Thanks

Perhaps as a test to make sure the media is reachable, replace the internal url with the external in settings.