Google_cloud TTS for Google Mini does not work since migration to Nabu Casa


So I had a configuration that worked and used google_cloud tts to, for instance, have my Google Mini devices say something
I used duckdns and portforwarding to enable the audio files to be reachable by Google.

Since then, I’ve migrated to Nabu Casa, but can’t seem to get it to work - the Google Mini gives a sound, indicating it wants to play something, but cannot reach the actual file.

My config is as follows:

# Text to speech
  - platform: google_cloud
    service_name: google_say
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300
    key_file: google_cloud_say_service_account.json
    language: nl-NL # <<<<<<<<<<< here
    gender: male #<<<<<<<<<<<<<<<< here
    voice: nl-NL-Wavenet-C #<<<<<<<<<<<<<<<<<< here
    encoding: linear16
    base_url: https://<NABU_CASA_ID>

And I have the External URL and Internal URL configured through the UI (General Configuration) to respectively, https://<NABU_CASA_ID> and https://<LOCAL_IP>:8123/

Any clue to help?

Weird, it works now. Nevermind!