Google Coral


I have a problem with installation with Google Coral.
Let me tell what I know. I have a Odroid N2+
That’s all

I’m from the DOS generation.
I know DOS, Basic, Pascal and Assembler but I know nothing to a little of Linux.
So if you ask me what OS I have and version, the answer is: I don’t know.
If you ask it, tell me how I can get this info.
And be a little patient with me, at my age it goes a little slower (74)

Now the problem:
I have Frigate wordking but get the warning:
CPU detectors are not recommended and should only be used for testing or for trial purposes.

I bought the Google Coral and want to install it.

In “Terminal” I enter: echo “deb Index of /apt// coral-edgetpu-stable main” | sudo tee /etc/apt/sources.list.d/coral-edgetpu.list

The reply is: tee: /etc/apt/sources.list.d/coral-edgetpu.list: No such file or directory
deb Index of /apt// coral-edgetpu-stable main

So I’m missing something.
Do I something wrong?

I will be very thankfull when you help me trou the problem(s).


Specifically, which Google coral do you have? The instructions are different.

If you ask it, tell me how I can get this info.

On the website where I bought, I read:

Google Edge TPU ML accelerator coprocessor (?)

The two main types are USB or PCIE of some form factor.

The question not understood.
It’s USB

You don’t need to do any of that to run the USB coral, just edit your frigate config

    type: edgetpu
    device: usb

Thanks working.

I thought I did it ones.
You see it’s the age.

Thanks again.


Hello everyone,
I have the same issue as Strikky.
I am not sure that I do not need any drivers or specific configuration with Home Assistant Terminal, but when I run Frigate (Full Access) the processor usage is very high (62%-90%). I have google accelerator (Get started with the USB Accelerator | Coral) which is connectet by USB 3.0 to the odroid N2+.
How the odroid N2+ or Frigate (Full Access) know which processor resorces should use?

My frigate.yml has included

type: edgetpu
device: usb

but maybe this information should be in specific order?
I will be grateful for any help.


Hello. I have a PCIe M2 Coral TPU. ¿How can install the drivers on HASSIO?

they are already installed

frigate.detectors.plugins.edgetpu_tfl ERROR : No EdgeTPU was detected. If you do not have a Coral device yet, you must configure CPU detectors

I’m using a NUC11 with a Celeron. The TPU is connected to the port where the WiFi module was previously connected. Is it necessary to configure anything else in the BIOS parameters? During the first boot, I lost the LAN connection, so I entered the BIOS and disabled the WiFi.

Make sure the device shows up in the hardware list

Okay, I checked the hardware list and the Coral device is not showing up. Maybe a BIOS parameter needs to be changed?

I’m completely lost on this issue. If I disable the Bluetooth and WiFi controllers in the BIOS, the HAOS starts correctly, but the Coral TPU is not detected. If I enable the Bluetooth and WiFi controllers in the BIOS setup, the HAOS starts, but I lose the Ethernet connection. When I enter the command “net info” in the CLI, this is the result:

I’m not sure this is correct? My Coral USB worked without it showing in the hardware list (although I did look for it for a day in the hardware list before checking the Frigate “system” tab only to find it there?

Fixed after some time spent reinstalling HAOS and restoring a complete backup.

Can i ask how you fixed it.
I have the coral m2 inserted in de slot for the wifi module and enabled it it in the bios.
I cannot see it in the hardware list.
I run hoas in a vm on truenas in priveliged mode.
I can see it if n truenas as pci 00:05:00,when i put in pci: 5 in the config it is still not reconized.