Google Domain not working

Google Domains is updating the dynamic dns record data with IPv6 address. How can I force it to resolve IPv4 address? I cannot able to connect to the UI using IPv6 address. Please help.

Can anyone please help me on this request?

you have an IPv4 address and need to create an A record.

It is dynamic dns in Google Domains. It will not allow to select between A & AAA records.

Can anyone please help me on this request?

This forum is for home assistant, and while there are some clever people here who might be able to help, Iā€™d suggest asking in the google support forums.

The issue is related to how home assistant handles the google domain component. Goggle domain support both A & AAA records. I can able to successfully modify the domain record correctly using shell script. Only thing I want here this component to work perfectly.

Ah, that makes sense, apologies

I had the same problem. If you are using hassio, you need to make sure that you go to Supervisor> System Host> ip address > change and make sure the ipv6 interface is disabled. It will then only advertise the ipv4 address to google domains.


This solves my issue with Home Assistant not being available externally. I recently got a new cable modem from my internet service provider and started having issues connecting. Thanks.