Google frustration!

I have set the Silicon Labs Multiprotocol as my preferred thread network on HA but because I had already added one device to the Nest Hub thread network, when I came to sync the preference, my phone stubbornly reported that it had its own preferred network and refused to back down. In the hopes it could be forced, I started to add a new device via the Home Assistant android app and eventually it popped up with the Google network and no other choice offered. So I backed out of the process intending to try some more tweaks and the wretched thing went ahead and completed the commissioning even though I had backed out! I cannot find anywhere how to actually disconnect a thread device from the Google network :rage:


I am not sure to understand your question.

You are searching to remove Matter devices from your google device ?

1 Like

I wasn’t sure there was a solution so it was a rant as much as anything, but yes I’d like to remove it from the Google physical thread network to try and have another go at getting it to connect to the SkyConnect network. I could factory reset it, but wasn’t sure if google would simply reclaim it once it came back online, and I have no tool to examine the network. Is there one?

Yes it’s possible.

It has to be done with Google Home app.

Have you tried this guide : Remove Google devices from the Google Home app - Chromecast Help.

To examine the network topology of the thread network you must use the OPTBR on HA.

Then on the configuration you should be able to allow ports for ex : 8085 and 8090
Then connecting with your standard adress to the HTTP port : homeassistant.local:8090

Then you should be able to reach the following topology :

but be aware that this functionnality is in beta stage.
I have devices randomly showing and disapearing, so maybe not a good reference (for now a least)

1 Like

Thanks for the reply. I’ve not ignored it but am still struggling to actually connect to the OTBR web gui via any port!

I know how to remove a device from Google Home but the plug in question was never added to Google Home, I actually added it directly to HA as its master controller (the device has appeared in HA’s device list), and I believe this accidentally was via Google’s Thread radio. If I can get into OTBR I might be able to find out for sure. Tried a few different port numbers… 8080 and 8081 were already set up but getting connection refused when trying those and others.

Edit: Ah those port settings only appear when I “show disabled ports” so I guess I am yet to find out how to enable them…

Go to your HA web UI → Parameters → Addons → OTBR → Configuration (tab) → At the bottom enable as follow :

Don’t foget to save !
Restart the OTBR on Info (tab)

you should now access to the web OTBR interface at http://homeassistant.local:8080/

1 Like

I’d done that before, tried again just now, still getting “homeassistant.local refused to connect” for http://homeassistant.local:8080/ while http://homeassistant.local:8123/ opens HA main interface just fine.

Checked our router firewall - can’t see anything obvious there. Is there anywhere else on HomeAssistant Green that ports can be configured or blocked? Does the webserver for the OTBR service reside on the SkyConnect dongle itself after installation?

Just in case it’s a problem with my chromebook settings I am going to fire up my Windows machine and try Edge or something.

Anyway just in case I still set something wrong here is my OTBR config after attempting to enable the ports. I saved and restarted HA.

Have you tried with the IP of the HA ?

Mine can be fetched from : Parameters → System → Network
Then clic on the 3 dots and Ip information :

Then use the IPV4 :

and type in the bar (for me ) :

1 Like

Yes I have tried direct IP address and it’s one that is reserved on the router. Also just tried MS Edge from my other PC. Same. Connection refused. Definitely seems like the port is not enabled or is otherwise blocked. Although I have tried other random port numbers with the same effect. What seems significant is when I searched, other people who had a similar problem that was solved by advice similar to yours - none of them started off with the “show disabled ports” toggle in their screenshots.

-It’s odd, can you show me what the console of the OTBR is displaying ? be sure to enable debug mode.

-If it helps, check this config :

-you have restarted the OTBR ?

-You have restarted the HA ?

1 Like

I’m an idiot I hadn’t clicked Start let alone Restart! I did at one time but something must have stopped it later. My OTBR firewall and NAT64 toggles were the other way round from yours but otherwise everything identical. What baud rate are you using? Anyway I restarted everything and also cleared cache and cookies from my browser. Tried again and got the same connection refused. I will finally try a full shutdown and unplug of HA and give it one more go.

Here’s a capture for the baud :

But don’t take it for granted as I run a custom firmware on ThreadOnly I picked on github and manual flash.
Also I have a bluetooth dongle ence 2 devices.

1 Like

Just before I did my shut down and power cycle, I noticed the following anomaly on the integrations page I’d not opened for ages, and it remained after rebooting. Left it half an hour now and it’s not resolving. Do you know what remedies I can try? It might have been like that since days without me noticing. It could be the key to the whole problem

Screenshot 2024-02-06 16.39.07

ah , I see the issue now.

yes it can be resolved by intializing the border router again, I am not sure how to fix this.

I will try this and give back to you a solution soon.