Google home / Alexa local since 2021.7

Hello Friends,

I use HA on a RPI. I joint it with HTTPS through a reverse proxy managed by my Synology NAS.

Suite aux d, je n’avais plus accès depuis l’extérieur et du coups les assistants vocaux ne fonctionnent plus eux aussi.
Following the last updates, I no longer had access from the outside and suddenly the voice assistants no longer work as well.
After some research, I saw that it was now necessary to add a few lines in the config to authorize the use of the reverse proxy.
So i added ‘use_x_forwarded_for : true’ ans the ‘trusted_proxies’ lines.
After that, my Access from outside works normally without problems.

However, impossible to use GH or Alexa.
I tried to
I tried to dissociate them, reassociate them without success. I Always have a error.

I searched a lot but I did not find any similar cases to mine.
I tried adding a ‘trusted_networks’ line as some seem to need with nginx but with no more success

Someone have an Idea? I must be wrong somewhere, but now I can’t find where.

Thanks for your help