Google Home (Assistant) not linking anymore (again)

Hello all
I am desperately trying to get my my Home Assistant and Google Home linked again.
I created everything new from scratch and now in the google home app when I try to add my [test] service, I get to the login screen from my home assistant and after clicking Login, I get “An error occured. Please try again” in the app and nothing gets linked.
I tried all possible configurations for the google_assistant, even only just specifying a project_id and api_key. Nothing helps, always the same error :frowning: This did work once when I created it about a year ago. I wanted to update the devices which didn’t work so I tried re-linking and now everything is gone.

My setup is:
HomeAssistant (latest) in docker in an ESXi-Ubuntu VM
Reverse Proxy on a Synology NAS with let’s encrypt certificates
External Domain with correct forwarding.

What is kind of special is that I am in a double-NAT scenario which I think can lead to problems when a device from he intranet tries to contact another device in the intranet by the external address. I fixed this by using my own internal DNS which forwards external addresses to my local addresses when used locally. To get google home to use that dns, I blocked port 53 UDP/TCP to ip and from the google home devices. Not sure if that is needed all all though.

I would really appreciate some help as I don’t know what else I can try. Also I cannot find any log messages in google home app or on HA.
Thanks a lot for your support

Hi there,
I read somewhere (can’t remember where) that this could happen if you have pinned Home Assistant to Start Screen of your Android Device.
Maybe removing this pinned Shortcut and trying to relink would help you?
Just guessing…


This worked for me. I’ve deleted the homescreen shortcut and then it linked without problems.

I don’t have an android device. I still have the same issue, I cannot get it to work.

Oh my god. I just found out that I once added a Firewall rule to block requests from outside my country. Google Assistant of course comes from America. After removing this rule, everything works again :smiley: