Google Home Doesn't Connect to Hass.IO

I am unable to get Google Home (And Nest, actually) to connect to Hass.IO. I am able to get VERRY close to the end of all the configuring, but when I try to add it to the Home Control devices on the Google Home app, it says “Couldn’t set the configuration. Check your network connection”. It seems like in any threads I find elsewhere, people just stop responding and the issue goes unresolved.

Let me know if there are any details you need.

  1. Your Home Assistant system is accessible from the Internet, with an SSL certificate from a commercial supplier or the likes of Let’s Encrypt?
  2. You’ve tried setting it up when not connected to your home WiFi?
  1. Yes. DuckDNS with LetsEncrypt is setup, and all my addons are set for SSL where possible.

  2. Yes. I used my phone to switch between Wifi and 4G, and tried on work Wifi as well. Same message.

Remember also that I’m using HassIO in case you were picturing Hassbian or the All-In-One installer.

Also, do I need to include my port in the links that various addons use? I’ve been using,
for example, https://[address]

I also have the following ports forwarded:

SSL: 443 to local 8123
HassIO: 8123 to local 8123
HTTP: 80 to local 80
Nest: 9553 to local 9553
Pi-Hole: 81 to local 81

And I think there’s more but I’m not home.

I had the same issue, realised that I hadn’t included port 8123 in the https URL in the project.json file. Once I corrected this I could link successfully.

This is just a matter of running the “gactions update” function again, right? I added the port, did the gactions update, and tried again, and it didn’t change anything.