Google Home & IFTTT

I am trying to get Google Home to post to IFTTT so that it controls Home Assistant however I am struggling to get this working. I am not really sure what I am doing wrong and was looking for some help. I setup a duckdns and forwarded port 8123 like was stated on the IFTTT component. Here is what I have for the IFTTT applet:



Content Type:

{ "entity_id": "switch.front_room_switch_6_0" }

I am not sure where to go to troubleshoot this but hopefully someone could point me in the right direction. I think my ddns is setup correctly. I can login from my phone with WiFi off but I am not sure that is right either. I have an Asus router and when I do the duckdns I am taken to AiCloud where I have to provide a login name and password.

Your are trying to access Home Assistant from your external ip address. Depending on what ip address your router gave the Home Assistant system, you need to use it to access the system locally. Being an Ubuntu user I always use something like this:

to access the system…

So your saying the url should be the ip address of the computer holding home assistant? I tried this and it still doesn’t work. Wouldn’t this have to be the external ip address because ifttt is trying to talk to my home assistant?

I did this for the first time yesterday as my phone has just received the Assistant update and it was impressively simple after you work out all the guides are out of date because maker is now maker webhooks with completely different branding and recipes are now applets!

The way you have set up IFTTT looks spot on and yes, you should be using the external address as you have done otherwise how would it find you over the internet.

This only leaves your set up of duckdns, your router or your configuration.yaml. Your mention of AiCloud(?) suggests at least the first option is iffy.

Two other things that might be at fault; the port in the URL and SSL itself if it’s going through Let’s Encrypt.

If you have SSL set up correctly and your router is forwarding any 443 requests made to the DDNS name to 8123 on your HA installation, you don’t need to specify the port. So the URL should be:

If it still isn’t working, you may want to look at this thread about certs and IFTTT:

I just tested this a few minutes ago and I was able to get it working using the URL example above and replacing it with my own domain. YMMV on the cert issue; I did make the change but not sure if this was needed as my first tests were done using the worng service. (Duh!) I was trying to turn off a switch using the light service and I discovered my mistake after making the cert changes in that thread.

I was able to finally get this to work. I am sure it was because I never did the let’s encrypt (I didn’t know this was needed.) Thanks for all the help. The only isSue I have now is that to access home assistant internally I have to use but not a huge deal I don’t think