Google Home Integration Not Working

Hi Everyone.

I’ve tried everything…so posting on the forum is literally my last resort. :frowning:

To give a bit of background. I run Home Assistant 0.106.6, in a Python VE on an Ubuntu Linux Server (18.04), and have been running smoothly for a long time.

Last week I went from version .98xx (i think), to the latest version after Ring has been added as an Integration (no issues there).

However, since the upgrade Google Home integration no longer works.
Now some background on my setup, and to remove the obvious assumptions:

  1. I do not use DuckDNS or Certbot to Publish. I have a static IP, that is published using a Godaddy Certificate (so no DuckDNS and Cert Issues here). Cert is valid & Publicly trusted.
  2. I know API Key is no longer supported in this version, so I followed the instructions on: went with a Service Account for Auth. (Service account is associated with the new project as well)
  3. I did create a brand new project in Got my projectID, added in the fullfilment URL. Have my HASS Authorization URLS, and Token URLS correctly defined.
  4. Have the Google Component added as per the example in my Configuration.yaml.
  5. Created the Service Account Key, gave it all the neccesary permissions etc.
  6. used service_account !include “jsonfilegeneratedbygoogle.json” in the yaml file.
  7. Homegraph API has been enabled for the project

My Issue is, once I get to google home, and try to link the account to hass, I get the authentication page, and after I enter my username & password, I get the spinning circle, and then nothing. It just returns me to the “Manage Accounts” page, and nothing is there.

All my exposed domains are correct, (worked previously under API_KEY), and the only errors I see is homegraph API errors (404), but I think that relates to Google Home not being able to connect to HASS for the initial sync.

I also disabled the report_state: true under the google_assistant yaml entry, whereafter the 404 goes away, but I am still unable to link Google Home with HASS.

I’ve looked everywhere for error logs, but cannot find any. I am out of ideas, could anyone PLEASE HELP?

Ok. So I got tis working now. And Thoughd I’d share my thoughts, and where I beleive the Home-Assistant configuration & documentation is lacking.

Maybe this will help you…

First of all, the instructions are correct, but they are not in the right order. Basically, from a high level:

  1. Create the new project. And because there is timeout issues, make sure you select the Region closets to your HASS install (if you run hass from the USA, you should be good, but if you run it from Slovakia, dont select USA as your locale).

  2. NEXT BEFORE DOING ANYTHING ELSE, grab the project ID (so you have it), dont configure any linking or actions yet. Create the Service Account as per the componnet instructions. Make sure you create the service account in your new project and not some old one. (select your project from the drop down list).

Also i did not use the !include, but I rather manually specified the key and email provided in the JSON file for the service account. Make sure you set the right access on the service account as per the component instructions.

Then Continue on your project, follow the rest of the instructions, get to the end, test, and then you account should be linked to google home just fine.

Hope this helps someone.