Google Home Integration - Unable to edit or create routines and save them


This was working before, and I don’t think it’s an HA issue, but more a Nabu Casa / Google Home issue, but I really can’t pinpoint what it is.

About a year ago I setup a couple routines in Google Home. To simplify it, I had a routine that turned off some lights at bed time when I said “time for bed” to my Google mini. When I try to edit that routine by adding another device, and then hit save, Google Home tells me that it can’t save my routine. I even went as far as creating new routines, tried to select a light from the list and telling it to turn on, but Google Home will NOT save the routine. It just says “Your changes could not be saved. Please try again.” If I instead type in the full command to the routine such as “Turn on master bedroom ceiling fan” and save it, it’s fine, and it will work. But that’s not really ideal when I used to be able to select devices from my integration list and select from the drop-down what I want to happen (turn on or turn off).

I did further testing and tried a simple Goolge Home routine that would modify the temp of my ecobee theromstat. I can select the thermostat from the list, change the temp, hit save, and it works. But, this was only using the ecobee app integration, not HA. It definitely seems to only be an issue with the cloud integration between HA and Google.

Am I the only one having this issue?

I’ve tried reinstalling the Google Home app on my phone, deleting the cache on my phone, unlinking the Nabu Casa cloud service from HA and then resyncing my devices, I’ve tried unlinking the Hass app within Google Home and then relinking it. I verified I can turn off the devices via the app and even via voice command to the Google mini, so the services are definitely talking. I even deleted the Google Home “home” I had setup in the app so I had a fresh start. I don’t know what else to try. It seems to be a bug. I did submit a support ticket to Nabu Casa, but I’m not sure if that’s really the right route to go because I don’t know where the problem is. My Alexa integration works fine, no issues. From within the Alexa app I can select each device and setup voice automations, no problem, but I can’t do it with Google Home…not unless I type a command to the device I want to interact with…I can’t select it from the list and then save it; it shows up in the list, but it doesn’t save. So weird.

Thank you all in advance.

I have the same problem. Used to be able to edit or add routines now I cant. Only when i try as you do to add devices to turn on or off.
Did you manage to fix?

Same issue here. frustrating…

I solved using “insert command” and not using the most used actions…
In this way i can save routines…

1 Like

I know, a bit late to respond. The issue ended up getting resolved by just waiting. I wiped everything out, waited a week or so, and it just went away. I can now add automations again and see my devices. Weird. It must have been a fluke.