Google Home issues with Home Assistant Cloud across VLANs

Tags: #<Tag:0x00007f326f4d3c00> #<Tag:0x00007f326f4d37f0>

My Unifi controller took a dump during a firmware upgrade and I ended up having to rebuild my network. I don’t have a lab and it was a mess so it wasn’t that big of a deal.

My HA server is on a different VLAN than my Google Home devices and I drop new traffic from the VLAN with my Google Home devices. My understanding/recollection was that using HA Cloud was a zero-config network setup and it should have worked. It worked occasionally but not often. I could not find repeatability to when it would work or not. I went ahead and created an address group for my Google Home devices and created a rule to allow traffic from those devices to the IP of my HA server. This fixed the problem for a couple of minutes, switch state appeared correct and I was able to turn on/off lights in both the Google Home app and my connected devices but everything has gone offline again and shows disconnected in the Google Home app.

I’ve unlinked and relinked my account several times in the Google Home app. I’ve resynced my entities from HA to Google. I went ahead and moved a single Google Home device to the same VLAN as my HA server. It worked, initially, but after a minute or two it stopped controlling my devices and stating they weren’t available. A minute after that it worked again. A minute after that it stopped working again.

If I look at the Logbook in HA I see an entry every minute that all my Google devices are turning off and becoming unavailable. If I tail my HA logs I see a ton of related errors.

home-assistant    | 2020-11-18T14:58:33.480624482Z 2020-11-18 09:58:33 ERROR (MainThread) [snitun.client.client_peer] Can't connect to SniTun server us-east-1.ui.nabu.casa:443
home-assistant    | 2020-11-18T14:58:33.481155009Z 2020-11-18 09:58:33 ERROR (MainThread) [hass_nabucasa.remote] Connection problem to snitun server
home-assistant    | 2020-11-18T14:58:37.106002337Z 2020-11-18 09:58:37 ERROR (Thread-59) [pychromecast.socket_client] [Bedroom Display(192.168.20.43):8009] Failed to connect to service Google-Nest-Hub-c63060342a0ba8c21c0def0b6b37b2b0._googlecast._tcp.local., retrying in 5.0s
home-assistant    | 2020-11-18T14:58:37.181044711Z 2020-11-18 09:58:37 ERROR (Thread-50) [pychromecast.socket_client] [Living Room Cast(192.168.20.51):8009] Failed to connect to service Chromecast-Ultra-8df27faeab5e8b854d56e8fe7cb911d7._googlecast._tcp.local., retrying in 5.0s

I decided to restart my HA container. Why not. After restarting I’m getting the following error messages in my logs.

home-assistant    | 2020-11-18T15:02:23.318494127Z 2020-11-18 10:02:23 ERROR (MainThread) [hass_nabucasa.remote] Can't update remote details from Home Assistant cloud
home-assistant    | 2020-11-18T15:02:38.336938166Z 2020-11-18 10:02:38 ERROR (MainThread) [hass_nabucasa.remote] Can't update remote details from Home Assistant cloud
home-assistant    | 2020-11-18T15:02:53.354804895Z 2020-11-18 10:02:53 ERROR (MainThread) [hass_nabucasa.remote] Can't update remote details from Home Assistant cloud

I’m still seeing the errors and my Google Home devices are not working.

I checked my Nabu Casa account. => Active user. You will be charged on Dec 17, 2020.

I tried to browse to my Remote Control URL and it does not resolve.

I don’t know what else to try. Any thought?

Interesting. It seems like my Remote Control URL is struggling. If the URL resolves then Google works, if the URL doesn’t resolve then Google doesn’t. I’m pretty confident that’s the problem. Is there a status page for HA services?