Google Home Mini - Error on init TTS: No TTS from google_translate

Hello guys!
I know there are a lot of topics about it, but i’ve implemented all tips and it still doesn’t work, i lost days and nights trying to fix this :cry:

My HA is runing on VirtualBox machine, i’ve a local IP for it (fixed on router by the MAC address).

DuckDNS with following config:

   accept_terms: true
   certfile: fullchain.pem
   keyfile: privkey.pem
 seconds: 300

NGINX with the config:

 certfile: fullchain.pem
 keyfile: privkey.pem
 hsts: max-age=31536000; includeSubDomains
 cloudflare: false
   active: false
   default: nginx_proxy_default*.conf
   servers: nginx_proxy/*.conf

DNSMask with the config:

 forwards: []
   - host:

My configuration.yaml

         max_entries: 100
         - platform: google_translate

My openned ports on router:

I can access my HA by or both works great, i can control the Google Home Mini, play music or mp3 audio link (using Service > media_player.play_media)

But if i try to use the service tts.google_translate_say I always get the error Error on init TTS: No TTS from google_translate

On my logs, when start the server:

 INFO (SyncWorker_3) [homeassistant.loader] Loaded google_translate from homeassistant.components.google_translate
 INFO (MainThread) [homeassistant.setup] Setting up tts
 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event service_registered[L]: domain=tts, service=google_translate_say>

When i try to use the service tts.google_translate_say:

 ERROR (MainThread) [homeassistant.components.google_translate.tts] Timeout for google speech
 ERROR (MainThread) [homeassistant.components.tts] Error on init TTS: No TTS from google_translate for 'hello'

Anybody can help me ??

i have the identical problem. did you manage to get is solved?

Aldi for me. Any idea?

same problem!

Try base_url with the port:

  - platform: google_translate
    language: 'es'

Hi @GTaylor, I am facing same TTS init problem now… did you find the solution? I will appreciate any suggestion.

Same for me

Anyone found a fix?

Tried the base url and didn’t work. Gave up and switched to reverso tts through HACS.

Thats is to bad… is there anyone who has an idee??

If have an synology with reverse proxy, and can’t get tts running on my nest mini. I can play a file from an internal link but this is abracadabra for me

1 Like

OK, so it’s not just me, good to know.

1 Like

I got same problem since yesterday, until then it worked fine … but I haven’t done any update or installation.
I tried with base_url without port, without base url (using internal) and with external as base url; with and without nginx proxy … same result always

Take a look here, for example. I posted a post there.

I see. I’ve just switched to Reverso TTS / tts on hacs, works perfectly

Can Reverso TTS read data from templates, such as temperature or time?

I’m testing now… wait a minute

yep, it works! :upside_down_face:

Thanks. I will decide if I will wait for the update until 13.12

Hello, version 0.118.5 fixed TTS for me

0.118.5 fixed for me as well. Here are the release notes including new Google TTS API component for the fix:

1 Like