Google Home trouble with responses from Nabu Casa

Hi there.

While there are several threads with people having connection problems between Google Home and Nabu Casa I have a more unique problem.
Every other day, when I execute commands (e.g. turn on/off lights, open/close blinds) via Google Home I get the usual response like “I can’t reach Home Assistant Cloud by Nabu Casa”. But the command is executed none the less, so e.g. my lights turn on but I stell get the error message.

I have observed this behavior and come to the conclusion (which may be correct or not) that the commands are transmitted from Google Home to Nabu Casa and HA, but there is no response to confirm the state (don’t know how the interface works exactly). Another thing I experienced is that it sometimes takes quite some time to load the state of devices on the display of my Nest Hub which reinforces my theory and I also get those messages on the display randomly without saying a command.

I can’t find anything in the logs (except for those snitun server errors which seem unrelated).

My setup: HA OS on a virtual machine. Nabu Casa subscription. Several Google Home devices (Home/Nest Mini, Nest Hub, Lenovo Smart Clock). Almost all appliances I use via voice commands have some kind of Shelly in the background. When I directly connect the devices to the cloud, I have no problems.

1 Like

I am having the same troubles.
I rebooted my system and cleared my logs.
I was able to then force the error by asking “hey google, turn on the lights”.
It gave me some error saying “nabu casa is unavailable”.

No error in the logs.
The lights did turn on with a delay though.

1 Like

This need to be fixed. HA team should add some debug option.

Bump. Still feeling this pain. Disabled IPv6 like some others but to no avail.

Check out this post for a possible fix. Nabu Casa not available error from Google Home - #25 by RickKramer

I too have the same issue and have been for months, with it seeming to get more frequent recently. The link suggests turning off IPv6 for those running HA on a VM, like me. I turned off IPv6 and devices seem to be responding more quickly than before and no “I can’t reach Home Assistant Cloud by Nabu Casa” so far, but more time will tell.

I’ve done that months ago. No change.
I’ll try to open a ticket.

Fortunately Google stopped to tell me the error message. It is just displayed on my Nest Hub. So it’s less annoying.

Since I’m also having remote login issues sometimes, I might switch back to manual configuration of the Google Assistant integration…

I opened a ticket and got this response:

We are re-writing the relayer which handles the communication between your instance and Amazon/Google and this is expected to be a large improvement over the current implementation. There should be much less latency and CPU usage on the backend and should be up in the next month or so.
I could have you try deleting hidden files and recreating your exposed devices, etc, but I’ve found that none of this helps in the long run. It may improve at first but the “device not responding” responses will slowly creep back in. We have simply gotten to a point where we have many more users and the same old resources and need to make changes.
Thanks for your patience!

So we’ll have to wait and see.


I came here searching for answers and it appears that everyone is reporting the same behavior that I’m observing.

I recently migrated to HA with over 300 devices and the connection to Nabu-Casa was the final step. I use Amazon and I am often met with 5+ second delays and the error messages. Sometimes the action will trigger, sometimes it won’t.

This experience has been very different than my cloud connections to voice assistants in ST, HE, and even the native app cloud connection and I thought it was something I was doing wrong or had set up wrong. After about a week, I stripped out all my light groupings because I thought that’s what could be slowing it down. I still have the same issue even if I’m just communicating with a singular bulb, or a group of bulbs from my lights.yaml or a group of bulbs grouped by Amazon.

My experience now makes sense given this ticketed response.

I have noticed that sometimes Amazon doesn’t seem to understand that it’s a bulb. Like telling me the bulb doesn’t support that. Sometimes the action will still fire, sometimes it won’t. I don’t know if that’s just an issue because of the delay.

I know in HE they had to add a button that told HE to force the command through without the response which reduced the errors. I’m not saying that’s the solution, but could be part of a multifaceted approach. At the end of the day, I think amazon just isn’t receiving the response it’s expecting in the timeframe it expects it and you get the wonky/inconsistent performance in the process.

Me 2 - watching

Issues got fixed for me with the newest changes.

Because you said this, I did some additional testing this morning. And yes, I can confirm the experience in general has improved sometime over the last month, I still had some (not too bed) popcorning going on. I thought this might be as a result of me calling multiple bulbs in alexa at one time (I previously ripped out my HA light groupings because I thought it was causing the poor performance with Nabu-Casa and Amazon).

Today, I put one of my light groupings back in. And while it eliminated the popcorning, it is SLOOOOOWWW. To the point it was hard to test it effectively.

Where can one go to verify that a fix went out and that I may be able to report sustained performance issues? Perhaps they were phased fixes and there’s more work for continued performance improvement?

Hello, I’ve been playing around with this issue for last couple of hours. Tried to disable ipv6 without luck. Also tried to restart HA few times and noticed that once entities not yet loaded in HA and I’m trying connect to google home at the same time app says that no devices available so it means connection between HA and Google home is working. So I went to /config/cloud/google-assistant and started to remove exposed entities for google home. Finally I left exposed only switches and lights and it connected and all my entities appeared in google home app. The problem was Gree Air Conditioner entities which become unavailable few weeks ago and once I removed exposure of the last entity of AC it connected straight away. Hope it will help. :slight_smile: