Google Home with Hassio

I am trying to use Google Home with Hassio. Here’s my config:

  type: google_home
  listen_port: 80

But, I don’t see anything at

The setcap command gives me the following error:

pi@raspberrypi:~ $ sudo setcap 'cap_net_bind_service=+ep' /srv/homeassistant/homeassistant_venv/bin/python3
Failed to set capabilities on file `/srv/homeassistant/homeassistant_venv/bin/python3' (Invalid argument)
The value of the capability argument is not permitted for a file. Or the file is not a regular (non-symlink) file

I am guessing, I need to change the path, but am not sure of the correct path. Any thoughts?

Strange it’s working for me with the same config as you. is your hassio machine right?

sudo setcap ‘cap_net_bind_service=+ep’ /usr/bin/python3.4

This worked for me.

I have some problems with hassio and google home.
i added the emulated hew in my config:

  type: google_home
  listen_port: 80

And i can access the
but the it give me an error:

500 Internal Server Error

Server got itself in trouble

In the log there is fallowing error:

2017-08-07 11:41:06 ERROR (MainThread) [aiohttp.server] Error handling request Traceback (most recent call last): File "/usr/lib/python3.6/site-packages/aiohttp/", line 422, in start resp = yield from self._request_handler(request) File "/usr/lib/python3.6/site-packages/aiohttp/", line 306, in _handle resp = yield from handler(request)

Any help is much appreciated.

My config is just that and it’s been working flawless along with Alexa.
Which IP have you wrote in host_ip, or Google Home?

Hi, thanks for your response.
The ip in the config is the’s ip address.
Apparently in there is a problem with google home and aiotp server.
I tried on hass io and hassbian without any success for now.
Will look more in to it later.

For it would be

I’m in the same situation, I can see the .xlm but get the same 500 server error when trying to see /api/pi/lights and /api/root/lights