Google Home without Discovery

I am trying to get all devices set up independantly of using the Discovery component. I have everything sorted except for my physical Google Home. I have it listed under the Platform: Cast settings but that doesnt make it show up as it does for normal chromecasts. Can someone please help out here? I really want discovery turned off because it is causing a duplicate for my android TV

I am also have the same problem, please help us

Currently, I do not believe this is possible. There must be something different about the way the GH reports itself as a cast device. Probably going to require an update of the component before it will work. In the meantime, as I also have duplicate devices, I have hidden them in the customize section.

I set up my first Google Home with the Discovery component on, but my new Google Home Mini without, so I expect it should work.

What does your configuration look like, here’s mine:

  - platform: cast
    name: google_home_mini

(and don’t forget to assign it to a group afterwards :slight_smile: )

Edit: I just realised that I did a complete reinstall of HomeAssistant after buying a Pi3 a few weeks ago. Didn’t turn on discovery and the the Google Home setup gave me no problems at all. (Hassbian on Stretch)

This is what I have in media_players.yaml

  - platform: cast

It picks up the second entry which is a chromecast audio, but not the first entry which is my Google Home.

I also tried the above code with name: included for each IP but it made no difference. Hass seems happy to get the names from the devices itself anyway as the correct names show up inn the front end as per what is saved in the devices

just found out that Hass doesnt like the two ‘host’ entries as above… time to try a few more things

I’m having trouble with chromecast audio and google home setup as cast on certain firmware. See here: Trouble with Chromecast Audio different firmware versions

well, after trial and error I figured it out. This works in my media_players.yaml

  - platform: cast
    name: Kitchen Home
  - platform: cast
    name: Lounge Speakers

I logged in to post the solution, but you beat me to it. Glad it’s working :slight_smile:

Hello guys!

Is it possible to manually add Google Home Mini groups created on the app?

I was previously using the discovery/integration method but now I need to use the regular Cast component and cannot see my speaker groups now.


from my experience the only way to get the Google device groups to show up in HA is using the discovery component. You can still use this with the Cast component

Thanks for your reply. Since I’m now using a segregated home/work network running two separated HA instances and both have cast devices, I would like to avoid/hide them from showing on the other network.

you can always hide them on one of the HA instances, or am I not quite understanding what you are trying to do?

Ok, so do you think I can add the cast component, set their IPs and also enable the integration at the same time? Thanks!

I use the Cast integration for my individual Google Home & Chromecast devices, the Discovery component for finding the groups of them and have static IP addresses configured in my router, assigned to the specific MAC addresses.