Google maps location sharing not updating anymore

I’ve been using Google maps location sharing for months since last week. Maybe since when I updated from 0.97 to 0.98 4 days ago.
From state I see:
last_seen: 2019-09-01T15:26:40.401000+00
Now is 2019-09-02 T 10:15
Any update reports home.
When there was the breaking change il 0.97 I changed the config and the existing coockie file worked perfectly .google_maps_location_sharing.cookies.xxxxxxx_gmail_com
I tried downloading the cookie file as suggested and tried using it insted with no result.
I tried to unshare and share again my location on maps, no result
I don’t know what to try. I’ve seen some post but referred to prior the breaking change in 0.97

Thanks for your help



I’ve had google maps working fine in 0.97 - since I installed 0.98 it updates when I restart HA, and possibly for a while after. Then it stops. I can’t see any related error messages.

So, if I understand, you have the same issue



It looks like I have a same issue.

Not sure whether this error is related it’s not very informative about what is logging it.

Unexpected error 'NoneType' object is not subscriptable

Are either of you getting it?

Maybe the problem is in the 98.1 relase. There is an update that reports to have solved the issue. I just updated. Lets see.



I have the same issue in 0.98 so it was not introduced in 0.98.1

Google api usage has been changed. Remove your password argument it has been deprecated. Starting working for me after restart.

I seem to have the same issue as well. Worked fine after 0.97, not working for the last few days.
There are no logs that seem to be related.

@eggman - I don’t have that error in my logs.
@advanbokhoven - My password has been removed since the last update. Was working fine since removing the password, but now is broken.

This seems to be related to this issue:

I have added the following to my config to test if it works as a workaround (as suggested in the issue thread):
scan_interval: 60

1 Like

i have the same problem since the update

The scan_interval fixed my issue. Seems to be a good workaround.

Did you check your logs? after 0.99 install I had a cookie file error and had to create a new text format cookie file.

Instructions on the integration docs page.