Google Meet - in meeting sensor


I already have sensor that is checking if I’m on meeting on Zoom or Teams.
But now I need to add Google Meet :slight_smile: Is there any way to do that?

best regads

As I use Google for work, from a work laptop, I wasn’t keen on installing anything locally due to security lock down on the device.
Instead I have fudged it so I forward all router logs to NodeRed then filter through these for any times the Meet ports are opened. Works so far when I open a meeting. Haven’t solved the ending of calls. I use node red to set a switch to ‘on’ then manually switch it off afterwards for now.

Happy to share more if that helps at all?

please share the code

There isn’t much to it within NodeRed.
Firstly I have an Asus router flashed with AsusMerlin which allows me to forward my router syslog to a syslog server - in this case the NodeRed instance. I then added the syslog NodeRed package - node-red-contrib-syslog-input. Hooked this up via a function to filter out the work laptop IP. Whenever the GoogleMeet ports are opened an input boolean is turned on.

[{"id":"f510fda4646dcdbf","type":"tab","label":"Flow 6","disabled":false,"info":""},{"id":"a126b90aa5cd6a82","type":"syslog-input","z":"f510fda4646dcdbf","name":"syslog","socktype":"udp","address":"","port":"20325","topic":"router","x":210,"y":140,"wires":[["eea04d0e8082114b"]]},{"id":"eea04d0e8082114b","type":"function","z":"f510fda4646dcdbf","name":"","func":"var payload=msg.payload.msg;\nmsg.payload=payload;\n    if (msg.payload.includes(\"DPT=19302\"))\n    {\n  return msg;\n    }\n    else if (msg.payload.includes(\"DPT=19303\"))\n    {\n  return msg;\n    }\n    else if  (msg.payload.includes(\"DPT=19304\"))\n    {\n  return msg;\n    }\n    else if  (msg.payload.includes(\"DPT=19305\"))\n    {\n  return msg;\n    }\n    else if  (msg.payload.includes(\"DPT=19306\"))\n    {\n  return msg;\n    }\n    else if  (msg.payload.includes(\"DPT=19307\"))\n    {\n  return msg;\n    }\n    else if  (msg.payload.includes(\"DPT=19308\"))\n    {\n  return msg;\n    }\n    else if (msg.payload.includes(\"DPT=19309\"))\n    {\n  return msg;\n    }\n","outputs":1,"noerr":0,"initialize":"","finalize":"","libs":[],"x":460,"y":140,"wires":[["e25328ea4e44a7e2"]]},{"id":"e25328ea4e44a7e2","type":"delay","z":"f510fda4646dcdbf","name":"","pauseType":"rate","timeout":"5","timeoutUnits":"seconds","rate":"1","nbRateUnits":"1","rateUnits":"minute","randomFirst":"1","randomLast":"5","randomUnits":"seconds","drop":true,"x":670,"y":180,"wires":[["0935b8614e58f93d"]]},{"id":"0935b8614e58f93d","type":"api-call-service","z":"f510fda4646dcdbf","name":"Turn On Work Call","server":"e934bd2b.1ee49","version":3,"debugenabled":false,"service_domain":"input_boolean","service":"turn_on","entityId":"input_boolean.work_call","data":"","dataType":"json","mergecontext":"","mustacheAltTags":false,"outputProperties":[],"queue":"none","x":1010,"y":220,"wires":[[]]},{"id":"e934bd2b.1ee49","type":"server","name":"Home Assistant","version":1,"legacy":false,"addon":true,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":true,"cacheJson":true}]

I also flashed my router with Asuswrt-Merlin but I don’t see such messages in the log. Any idea how I can enable them? I’ll note that I haven’t forwarded anything to Node-RED and I’m currently just looking at the syslog in the web interface, but I assume this would show the same messages.