Google Nest Integration - Cloud Project ID error at end of setup

Hi, I’m getting an error setting up the Nest integration, so I can connect my Nest Doorbell to HA.

I’ve followed the Nest Integration instructions, double-checked that I did all of the google setup and HA integration settings right, and all seems to be correct.

At the end of the HA “+ Add Integration” setup wizard for Nest, after entering all of the google information, I click “Link Account” on the OAuth page, HA then gives me an error, “Please enter a valid Cloud Project ID (check Cloud Console)”. I have triple-checked that the Google Cloud Project ID is the same that is listed in my Google console.

Checking Settings > System > Logs, I see this error:

Logger: homeassistant.components.nest.config_flow
Source: components/nest/
Integration: Google Nest (documentation, issues)
First occurred: 11:57:14 AM (4 occurrences)
Last logged: 12:11:51 PM

Configuration error creating subscription: Failed to create subscriber 'projects/verdugo-358500/subscriptions/home-assistant-2H7GKwnzlm' (cloud project id incorrect?)
Configuration error creating subscription: Failed to create subscriber 'projects/verdugo-358500/subscriptions/home-assistant-nVjZ9DqS4A' (cloud project id incorrect?)
Configuration error creating subscription: Failed to create subscriber 'projects/verdugo-358500/subscriptions/home-assistant-XtOPKzqAv2' (cloud project id incorrect?)
Configuration error creating subscription: Failed to create subscriber 'projects/verdugo-358500/subscriptions/home-assistant-N60Fs21CAS' (cloud project id incorrect?)

The multiple entries are because I tried entering the project ID multiple times.

I’ve checked the troubleshooting section of the docs, and there doesn’t seem to be mention of my issue. I’ve searched the forums, and while there was a passing mention of this error, it seemed like it may have been caused by an unrelated issue, as the OP had a different setup from mine? (Custom external URL instead of using Here is my system information:

Home Assistant 2022.10.5
Supervisor 2022.10.0
Operating System 9.3
Frontend 20221010.0 - latest

As I mentioned, I walked through all of the google setup again, and made sure everything was set up according to the instructions on the Nest Integration documentation page, and all seems in order. What else can I try to troubleshoot this, please?

I was hoping to get the doorbell working in time for trick-or-treaters tonight. :sweat_smile: Fingers crossed!


I think I may have fixed it. In the Google Device Access Console project, I noticed that the “Pub/Sub Topic” said “Disabled”. I clicked to Enable it, and then went through the Integration setup again in HA — this time it connected successfully!


Just had the same thing happen to me, and your solution worked; thank you!

This was an existing Device Access Console project that I set up a couple of months ago but hadn’t used for a while. I wonder if it’s auto-disabling pubsub after being unused for some time.


Ah yeah, it was the same for me. Set it up a couple of months ago, but ended up not having time to finish setting it up because we were moving into a new house, and just came back to it, now that we’re settling in.

Still a valid solution. Was beating my head on desk and changing pub/sub to enabled allowed the project id to be accepted.

1 Like

Hm, im still getting this, even with Pub Sub being enabled :confused:

Thanks for mentioning this. This fixed my problem.

Worked like a charm for me as well - still seems to be a common cause of pain.

This fixed things for me as well, also to be clear, it was disabled in the nest device console, not the google cloud side.

1 Like

Thank you !!!

That worked for me too! And to think I almost enabled the pub/sub option last night when i spent hours trying to get it integrated to HA again!

Hey there

I was having the same issue that the project ID was giving this error


On my tenth attempt to follow the instructions etc … I realised that I have created the nest connection with my primary google account, instead of the gmail account I am using as a shared account for the home server

Needless to say … the connection is now working and the only change I have made was

  1. Deleted the original connect using my primary gmail account at
  2. Changed my google account to the secondary (shared) gmail account
  3. Paid another $5
  4. Followed the instructions on Google Nest - Home Assistant under section “create a device access project”
  5. Started the integration setup again from home assistant settings
  6. Integration now works !

Hope this helps …

I am having a similar issue; check pub/sub topic was enabled. I only have one Gmail account, so it shouldn’t be an account issue.

Thanks! This one was what I was missing!

Yee Haw!

That was it.


A year later and your solution solved my problem. THANK YOU!!

1 Like

The amount of times I visited the page to retrieve the Project ID (months trying to get this to work…) and glossed over the Pub/Sub enable setting without even knowing to look for it… :crazy_face: Thank you everyone involved :raised_hands:

Ahh yes, thanks for clarifying, this was my issue

Hi, I am still struggling with this despite trying every troubleshooting advice that I can find.
I know I am entering the right credentials
I only have one Gmail account
Pub sub is enabled
After entering my credentials I am taken to the “Choose an account page” and after clicking on me, I get the error “Something went wrong Please contact the developer of this app if the issue persists”.
I see that Alex Leicester has got it working with a new email address but is it possible to delete the project and get new credentials with the original email address?

Thank you. This worked for me.