Google Nest Integration Without Nabu Casa

So first I should explain my setup. I have two raspberry pi’s - one that’s running Home Assistant, and another that’s hosting a website with Nginx.

I’ve followed all the steps in the guide here except I want to use my own domain, rather than Nabu Casa. What I figured I would do is create a location off the website (/nestauth) that would proxy forward to my local HA pi (http://[HApiIP]:[port]/auth/external/callback). So I added that URL to allowed redirects in google credentials (replacing the local IP with https://[myDomain]/nestauth).

The problem I’m running into is whenever I try to add the integration in HA, the redirect URL that’s given to google is my local HA hostname.

This happens regardless of what information I have in Settings -->General–> External/Internal URL

I thought I found a way around this by editing the URL that is hit when clicking the “Open Website” button when creating the integration. When I do this, I actually get the option to log into my google account and set permissions. But after going through the steps of allowing permission to my domain, the final screen is just all white and there is a 500 (internal server error) in the browser dev console.

Any ideas?

Hi, you need to access home assistant from the domain you would like to use, then it will be used as the redirect uri.