Google Nest "Kein Zugriff auf Partner" "No access to partner"

Dear guys,

i follow the setup guid for the nest integration. everything works finde. but, if i click on “integrate” on homeassistant, i got the error:

“Kein Zugriff auf Partner
Die Informationen konnten nicht abgerufen werden. Bitte wende dich an HomeAssistant, um zu bestätigen, dass dein Konto korrekt eingerichtet wurde. Möglicherweise musst du die E-Mail-Adresse des Entwicklers als Haushaltsmitglied in den Einstellungen der Google Home App hinzufügen.”

Englisch:
“No access to partners
The information could not be obtained. Please contact HomeAssistant to confirm that your account has been set up correctly. You may need to add the developer’s email address as a household member in the Google Home app settings.”

Yes, my email-address is the householder / administrator in my Google-Home app.
Yes i can reach my auth-url truh the (duckdns, ssl).

I dont know how to find more … log ?

Thank you guys :slight_smile:
paD

Same issue for me. I tried adding the email address I use to login to Nabu Casa to Google Home, but still same result.

yh, i add a new google-account, add it to my home, put it as the owner, nothing help.
i love the nest hardware, so it would be very nice with HA, but may i have to send it back :frowning:

No one? Its so annoying :frowning:

I have the same problem. I have double-and triple-checked all settings and followed the guide but still get: “No access to partner”.

Same problem I’ve been having the last couple days. Tried everything multiple times. Using Nabu Casa and not a G Suite username.

Same issue and no solution :frowning:

Same here, I have deleted and created from scratch 3 times with same result

Same issue here as well. Google troubleshooting isn’t much help below:

No access to partner

|Message|

Information could not be retrieved. Please contact PARTNER to verify that your account has been properly set up. You may need to add the developer email address as a home member in the Google Home app settings.

|Description|

This version of the error applies to the Device Access Sandbox and occurs when the Google account used with PCM is not an authorized account on the structure being linked. Make sure the Google account is a member of the home listed in the Google Home app.

See Share a home and devices in the Google Home app for instructions on how to manage home members.

This is what i tried

Went over the steps 3 times to validate everything
tried different subscriber_ids (full path, only id, subscriber_id replaced in example)
Added my nabucasa mail to the users
linked google home with home assistant (works but the other way around)

The only thing i find weird is that the pub/sub topic in the cloud is not the same as in the device access console. I made sure it had the same topic name but in the device access console it says
projects/sdm-prod/topics/TOPIC_NAME
and in the pub/sub topic it says
projects/MY_PROJECT/topics/TOPIC_NAME

Since my project is not sdm-prod it is not exactly the same. Maybe that is something to change and you need to make a project called sdm-prod even though the tutorial does not say it has. Will look into it later since i have to go now but this is all that i have worth sharing for the moment

I too cannot get past the No Access to Partner page. After going through the extensive setup disappointing that I cannot move forward. Any suggestions out there ? Is this a new problem ?

I tried adding the Nest integration again (did not change anything), and this time I was taken to the authorization page where I select/deselect what what Nest events/access i want to authorize. A step closer, however I received the below error. TIme to tinker more i suppose.

Authorization Error
Error 400: redirect_uri_mismatch

You can’t sign in to this app because it doesn’t comply with Google’s OAuth 2.0 policy.

If you’re the app developer, register the redirect URI in the Google Cloud Console.

See Nest - Home Assistant

For others: No access to partner may mean your oauth setup missed something. Set to testing rather than production? Double check all the steps.

Hi, You need to enter topic name manually.

Thanks @allenporter. Changing the Publishing Status to Testing made it work for me.

For others who don’t know how to that:
Go to the Google API Console and then click on OAuth consent screen on the left side menu. Here you will find the Publishing Status. If this is not set to Testing click the button to change it back to that.

You set it to Testing? My impression was that it needs to be be Production i thought. If set to testing, you’ll get logged out every few days.

Ahhh I misread your comment above I can see now. But for some reason that made it work. I will try and set it back to production and see if it still works.