Google "secure_devices_pin" issue with Envisalink integration (alarm_control_panel)

I have the Google integration setup and working:

  project_id: XXX
  service_account: !include google.json
  report_state: false
  secure_devices_pin: !secret google_pin
    - cover
    - sensor
    - light
    - alarm_control_panel

My garage doors are configured as “device_class: garage” which causes the pin to be required when opening. This is working fine.

I also have Envisalink setup for my DSC alarm panel. This is working in Home Assistant; however, when I try to control using voice - it asks for a PIN then appears to ignore the response. Instead it searches on my PIN (as if the conversation ended - and restarted).

I am currently using a different secure_devices_pin than the alarm_control_panel code; but, I did try making them match as well - same result.

  panel_type: DSC
  user_name: user
  password: !secret envisalink_password
  code: !secret envisalink_code
  evl_version: 4
      name: 'XXX'
      type: 'opening'

One interesting note is that on my Google Home Hub (screen) - if I ask to arm the alarm on it - it displays a keypad on the screen, and if I type it in - it works as expected.

This leads me to believe the secure_devices_pin is working as expected, but something is off with the Google voice conversation or mappings.

Anyone else experiencing this? Saw other threads with voice issues, wondering if anyone else tried on a device with a screen to type in the PI.

Slightly different use case, but very similar behaviour…

I’ve had this intermittently for my Garage Door (exposed to Google Assistant via Nabu Casa) with a secure pin when using it on a Pixel 3.

In my use case it seems to be the result of a Play Services / Google App / Assistant update on the phone itself and typically a reboot fixes it immediately.
I base this conclusion on the fact that my wife typically has the same issue on her Pixel 3 within a few days of me, also resolved by rebooting the device.

Interesting, I’ll give that a try tonight when I get home.

Still no luck on this. Garage doors are prompting and accepting the code as expected.

If anyone else has ideas, let me know!

Seems to be a voice problem - typing in the code when using the Google Home Hub works fine.

I’m having the same issue with my garage door. Mine is configured by MQTT.

After give the pin, google assistant make a search with my pin. I tried writting it, but i get same result, it didn’t work.

Can someone help with this?

I’m seeing the same with my garage doors too - started this week. The Secure pin just performs a search on the number, Arg.

The best options to try are:

  • sync entities from HomeAssistant
  • use the Assistant command “sync my devices”
  • restart the phone

1 or more of the above usually sorts it out for me.
(Until the next time)

Before my last post, I have already tried the next options and none of them worked for me:

  • Reboot my phone and Home Assistant
  • Uninstall google home and all updates of google assistant and install it again
  • Ask google to sync my devices

I experimented the issue for one week but finally it works again. I don’t know what happened, but now something I note different is that google now ask for a secure code and before it asked for a pin. Maybe it was an update of google

That’s interesting - it used to ask for secure code sometime ago but then switched to pin.

This is 100% the root cause of the issue, hence my list of things to try.