Google Services whole dont work anymore on my router (Home Assistant and Android)

im in need of desperately help.

I configured a lot of smart home devices in my network and imported them into my home assistant, i was new to home assistant, everything worked fine, and then i switched my router to the new Fritz.Box 7590, after the switch with a backup from the old router everything worked fine until one day everything related to google stopped working.

All my Google Nest and Google Home Devices stopped reacting to voice commands, they light up when i talk to them, but they dont listen after. After 10 Seconds google says: "Something went wrong, please try again in some seconds).

Also on my Android Phone, all google service using apps Load for hours now if i use the local wireless lan network. When i switch to mobile internet or if i use a vpn on my wireless lan, it works as normaly.

I had a call with google and they said its not related to them, because i asked if they blocked my ip or something, they said, they dont do something like that and that the failure is inside my router.

Now ive tried kind of everything ive found on the internet, but it didnt change anything.

There is some kind of delay in the Google Services, because when i wait for 30 seconds in an app, it starts loading things, also when i send a voice command from home assistant to one of my nest speakers, it speaks, but its after 30-120 seconds.

Ive implemented like 100 smart Home devices into my router (blinds, light switches, led stripes, floor heater, door…everything), that are behind closed walls now, and if i need to reset the router, im done, my wife will “kill” me for opening all the walls in the fresh build home.

Please is here someone that maybe knows the solution for this problem, im ready to pay someone to help me if its needed.

Things ive tried: Chaning DNS to google dns v4 and v6, switching wlan 6 to wlan 4, changing the channel, deleting all google devices and implementing them again. The devices work on other networks as intended.

Things ive done before the problem occured: Trying to implement google nest doorbell into home assistant, updating the router (It did it without permission), Chaning the router from Fritz.Box 7490 to 7590.

Sry for my poor english skills, im not a native speaker.

Thank you in advance, i would be more then grateful if you could give me a hint.