Google sheet integration error

Hi guys. I need your help please
I setup the google sheet integration and everything did well, in the end i received the success from HA and the link to the google shhet file…the problem came after. I tried to test the integration on Devtools-services-google sheets:append to sheet but on the line 'Sheet(the sheet to add data to) there is nothing i can select and on all the tutorial i see there is something to select (worksheet) so even if i complete the rest of the configuration it gives me this error:

Error handling message: required key not provided @ data[‘config_entry’]

I run out of ideas…i tried to create another project on google console, tried another email and even another auth key and secret key but i keep on having this unknown ‘config_entry’ issue…
What am i missing here??
Thanks in advance.

1 Like

What is the yaml you have tried to use?
Posting a picture of the service call with nothing in it says nothing.

Here it is.
There is no ‘config_entry’ in yaml like it should:

service: google_sheets.append_sheet
worksheet: Sheet1
Device: sensor
Temp: 24

It was only to show that the “integration” is not appearing on the sheet option…

Could you post the code inside a code block so that we can see it formatted?

</> button

@Hellis81 I really appreciate your help…
But i think you are not getting the point.
What i want to show is that after all the instalation of the integration, i am not getting the “integration” that should appear in front of the “sheet” option…
I print screen from youtube how it should appear, so you can see what i mean and eventually someone had the same problem…
Thank you again

I’m not going to even try and help you if you don’t post the yaml correctly.
YouTube videos is NOT a guide. The official docs is.

Hi Hellis

I have the same issue as OP and this seems to be the first topic about it.

Here is my Yaml (please note I am quite new to HA, code, this forum, … and still have to learn A LOT):

service: google_sheets.append_sheet
  worksheet: Blad1

I think there is a line missing. I already tried to ad a line (between service and data) Integration: Google Sheets but this did not change anything.

In home-assistant.log, I found the following log:

2022-11-15 22:33:08.615 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [547493859616] Error handling message: required key not provided @ data['config_entry']. Got None
required key not provided @ data['data']. Got None (invalid_format) from fe80::527f:28dd:be9f:d434 (Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36)

Thanks in advance!


You are missing the data and what key/values to send to the sheet.

service: google_sheets.append_sheet
  worksheet: Blad1
    somekey: "some value"
    other_key: 12

Hello, I have the same problem, but what is more strange is that about a month ago (12.10.2022) cant I created the integration worked and uploaded the data into GoogleSheet.
Is it possible from some update from Google or maybe even from HA that the integration is not showing up for me to select?
… or maybe you know another cause?
service: google_sheets.append_sheet
…worksheet: Sheet1
… .Temp1: 23
… the dots in the code are just to format the post.

Unfortunately I can’t add pictures to the post …


Hello , I’m back with a fix that worked for me.

I succeeded in yaml mode and after finding the “entry_id” (config_entry) in “core.config_entries” and copied the integration id from there.
Helped by the posts here: Google Sheets: Cannot see the config_entry · Issue #14285 · home-assistant/frontend · GitHub

I hope it works out for you…


I tried to add entry_id, but this did not help.

Can you copy your yaml to see what I did wrong?

Thanks in advance!

Good to know, i am not the only one with this issue…
Thanks for all your feedback here, guys :+1:

Hi, I put a picture of what I have set up.
At the top is the configuration from yaml and below is what I have in the “core.config_entries” file. You can also open it from Terminal.

1 Like

hi, i have the same problem. I followed the official home assistant guide: Google Sheets - Home Assistant.
I have also seen several tutorials on youtube. Everything seems to be fine, I install the integration but I have the same problem as paulsobral. There seems to be no entry after “the sheet to add data to”. The sheet on google drive exists but no automation writes to it.
“call Service” is disabled and if you try to click it gives the message “Invocation of the google_sheets.append_sheet service failed. required key not provided @ data[‘config_entry’]. Got None”. I did a lot of tests with different google accounts

1 Like

Great. Thanks for the screenshot. It helped!
Opened the file from /home/homeassistant/.homeassistant/.storage/core.config_entries

Scroll to bottom of the file and foudn that config_entry number.

Using that fixed the issue.