Google Sheets Credentials Error

I’m using HomeAssistant 2.2023 and I just tried to add a Google Sheets Integration. Upon entering the name, Oauth Client and Secret, I get a Google screen indicating that the Access is blocked. Unfortunately, now it seems it corrupted something in HA because Sheets does not appear as integrated and when I try to integrate with Google again, it skips the credentials screen and shows me the google message indicating Access is blocked.

I imagine the credentials are in some config in HA, but I don’t know where to delete them. Any suggestions?


Hey did you end up figuring this out? I am in the same situation and Im getting Error 400: redirect_uri_mismatch

So the way to reset the credentials is explained here: Application Credentials - Home Assistant (

What I ended up doing to solve my issue is followed the troubleshooting instructions here and re-set up my credentials using the new my.homeassistant redirect link.

Google Nest - Home Assistant (

Yes, I finally did find the application credentials in the UI - not really the best place to put this. Unfortunately, I already solved it by finding the hidden directory where home assistant stores these credentials and deleted them manually. It worked, but the link that you provided is the easier solution.

Thanks for posting this for the next soul that encounters this issue.

hi, I have the same problem with accessing google sheets “Error 400: redirect_uri_mismatch”. I followed the guide, created the project, web application, entered the URI: “” but it still gives the same error. any help please? Thank you

solved, I had not enabled the google drive api