Google TTS - GH responds to sent messages

I’m using the Google TTS component, and use it within Node-RED.

One of my vocal commands fires off a few activities in Node-RED, one of which is TTS. The issue I have is, my GH is responding to what the TTS says.

Is there a way around this (other than turning off continued conversation)?

I’ve never seen this happen before. Can you share what your action and message are?

Thanks for the reply.

I’m using Nora, and Node-RED, here’s what it looks like.


The TTS says ‘Have a great day’, which GH will reply to in a few different ways.

and the code.

[{“id”:“5f39371d.b771d8”,“type”:“change”,“z”:“152f56f9.aa0999”,“name”:“”,“rules”:[{“t”:“set”,“p”:“ip”,“pt”:“msg”,“to”:“”,“tot”:“str”},{“t”:“set”,“p”:“message”,“pt”:“msg”,“to”:“Have a great day today”,“tot”:“str”},{“t”:“set”,“p”:“language”,“pt”:“msg”,“to”:“En”,“tot”:“str”}],“action”:“”,“property”:“”,“from”:“”,“to”:“”,“reg”:false,“x”:380,“y”:120,“wires”:[[“64422d9.55ee8d4”]]}]

Really not sure about Nora. Seems like it may be an issue there, in which case not sure how much help the HA forums will be.

I use the home-assistant tts.google_translate_say service call directly to the Google Home device and all it does is say what is in the "message" field.

If you jump over to the Developer Tools > Service tab in Home Assistant and drop this in, what happens?:

Service: tts.google_translate_say
Service Data:

entity_id: media_player.googlehome9198 # or whatever the entity id is of your google home
message: Have a great day

Running the Service works as expected, with no response from GH.

Nora brings Google switches and scenes to Node-RED, so what I think it happening is; I use my voice to activate the scene using Nora, TTS fires, and the GH thinks the TTS was a follow up comment (continued conversation).

I think I may know what this is.

If you have your Google Home set to continue listening after a command is received, depending on the way Nora is sending the TTS, Google may not realize that the TTS is in response to the vocal request you made. Temporarily turn off the feature that allows you to make a second request after the first without saying “Ok Google”. This might be called “Follow Up” mode. But, that might also be what Alexa calls that feature. I can’t remember.

If this solves the problem, you may want to look into how to send a voice response for the request instead of sending the response as TTS. One is actually part of the response message that goes through the Google API. The other is a separate event that just happens to be related to the request you made.