Google TTS on Sonos device is not working

Hi all,

Does anybody know if Google TTS is working on a Sonos device? When I use the same code for a Google Home it’s working, but when I change the entity to my Sonos Beam it doesn’t.

The only logging for my Sonos I see is:
Changed to Paused triggered by service tts.google_translate_say

The logging for my Google Home device is as following:

Changed to Idle triggered by service tts.google_translate_say
Changed to Playing triggered by service tts.google_translate_say
Changed to Idle triggered by service tts.google_translate_say

My simple configuration to test:

service: tts.google_translate_say
  entity_id: media_player.living_room
  language: en
  message: "This is a test"

I just tried it and it works using Sonos One. I don’t have a Beam to test but I would be surprised if the Sonos speaker model is the cause of the problem.

Played the following using Developer Tools > Services.

service: tts.google_translate_say
  entity_id: media_player.living_room
  message: This is a test.
  language: en

Thnx, I will try later today!

Unfortunately it’s still not working using Developer Tools. Very strange because I also think the model shouldn’t matter. I can play my mp3 doorbell sound on it, but TTS doesn’t.

Already deleted and reinstalled the integration, but no luck. Maybe I should try a factory reset on my Beam…

Confirm you can control the Beam from Home Assistant by making it play one of your Sonos Favorites. If that works, confirm you can play a local music file to the Beam. The goal here is to determine how much does/doesn’t work.

I can control the Beam to play Sonos facorites and Spotify.
I can play local files to the Beam like my doorbell mp3 sound.

I just tried TTS using the Media browser, also not successful.

FWIW, I just tried that as well and it worked with Google TTS (and IBM Watson TTS).

Given that I can’t replicate the failure you’re experiencing, I can’t perform experiments to identify a cause. You can post it as an Issue in the GitHub Core repository (explaining the many ways it does work, except for Google TTS) and hope the author of the Sonos integration knows the reason.

I got it, I got it, I got it!

I was still using:


I removed base_url and I configured my url via settings > network.

Thanks for your help @123

1 Like

Glad to hear it wasn’t caused by the Sonos integration.

I don’t see base_url mentioned in the documentation for Google TTS (nor in the general reference for TTS). Is that a deprecated option that was left behind in your configuration?

That’s right, it’s deprecated.

Apparently Google/Nest Mini’s keep working while Sonos is not. This was misleading for me.