Google TTS with HA Cloud

I recently swapped from having a port open on my router to using HA cloud. In the interim there was a point where I was using HA Cloud but hadn’t yet disabled the open port. It would seem that as soon as the port was closed, Google TTS stopped working. Is there something specific that I need to change in my HA config to get it working again?

Currently the config for TTS is standard as per the docs.

  - platform: google_translate

If an automation with a TTS service call runs, the Google Home device makes the connection sound but then no TTS occurs. I can’t see anything relating to this in the log.

Any ideas?

Have a search on the forums for nat loopback (hairpinning) hopefully your router can be setup to use it

This worked for me

I did read about using the local IP address of the HA server but there was also talk in that thread about NGINX and stuff so wasn’t sure if it was the solution I needed.

Is what you have something like this?

  - platform: google _translate
    base_url: http://192.168.x.xx:8123

…with the base_url above being your HA server?

I found that here but as I say, was a bit confused as to if it applied to my setup or not.

As long as you don’t have ssl enabled in the http section, that should work. Google home devices cannot validate ssl certificates to local ip addresses, so your internal connection cannot use ssl.
You don’t need to worry about nginx if you’re using the HA cloud, as all your external connections go through the cloud.

I’ll give it a try, thanks

Hi, I make an UP to this topic, in order to know how to let TTS service work with an istance which is usinh HA Cloud via NabuCasa.
my configuration is:

  - platform: google_translate
    service_name: google_say
    language: 'it'
    cache_dir: /tmp/tts
    time_memory: 300

is it right? I’ve got to say that in the past I used DuckDNS to access to my istance, and after, due to internet connection changed, I passed to nabucasa cloud service.

thanks in advance for you help.


To get TTS to work (with nabu casa) I have the below setting in my config:

tts: # Text to speech
  - platform: google_translate

…where that IP address is the IP of the Hme Assistant server. So yours should work if you change the base_url to the local IP address.

1 Like

At the end it works, but partially: if i call the service from developer tools it says what I let it say, but if I use the service i.e. on a script, it does not talk…I must keep on trying.