Google TTS with VLC media player not saying the firsts words


I just install the home assistant v0,36, and I tried to send audio to VLC media player. I send the text from the front end, in the “text to say” but something really strange happens.

I can hear thet text, but it not starts from the first word, for example if I write: “Hello, I’m speaking from the frontend” it starts more less about the fourth o fiveth word, in this pharse, I will hear “from the frontend”.

Do you know why it have this delay? My configuration in configuration.yaml is:


  • platform: google
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300

Thanks a lot!


I tried with other TTS and the result is the same, and sending a message through RestFull API, the same. Therefore the problems appear to be in the media playerr. Is there any way to delay its reprodution in order to start when the media_player is ready?



Yesterday finally saw the solution. I install a new audio usb card to the raspberr, and It is connected through 3,5 jack. In this way the audio plays perfectly and all the phrase is listened.

So it appears that vlc trought HDMI has a little delay and is better connected to the jack.