Gosund dimmer integration

Hello,
Can someone point me to steps to integrate this dimmer?
https://www.amazon.com/Gosund-Dimmer-Switch-Control-Required/dp/B07VP4PHJJ

check out

think he done tho ones

Were you ever able to get these switches working ? i got a couple of them and just started looking to integrate them

Maybe you figured this out already, but if not I just did this and here’s what worked. I bought a pack of the dimmers (https://www.amazon.com/dp/B07VP4PHJJ/) and got them working by using the Tuya “Smart Life” app to register them and then using the Tuya integration. Not the Gosund app. After installing the integration and restarting HA restart the dimmer was detected and works perfectly.

Initially I installed the dimmer and registered it via the Gosund app, and then discovered a few threads saying to use the Smart Life app instead. I removed the dimmer from Gosund, installed Smart Life (which is identical to the Gosund app, guessing Gosund is the rebrand) and re-registered it. At that point the Tuya component was able to authenticate and after a HA restart found it right away. Even tho the app is identical, the integration wouldn’t work with the Gosund account.

There’s also this thread that goes into detail about flashing the devices and then being able to use MQTT to control them locally, which is sweet but for the time being the smart life integration works fine. Playing with the dimmer in HA the response is near instantaneous and i have no inclination to screw around further as long as the app keeps working. Wifi Gosund plug

3 Likes

I still have been unable to get my Gosund dimmer switches to work. I did as @wabbastang advised and removed them from the Gosund app, then installed the Tuya app. Reintegrated with the new app and the dimmer shows up on my network and works fine. But when I attempted to integrate into HA, it said “aborted” when within the Tuya integration I specified the “Tuya” app or the “SmartLife” app. No dice for either. I used 1 as the country code (I’m in USA).

So I’ve made a bit of progress. I was using the Tuya app which did not work for me. However, when I used the Smart Life app, the integration did work. However, the two light switches have not yet shown up within HA for me as of yet, though at least the integration credentials were accepted. Baby steps…

EDIT: Just took about 10 minutes for the entities to load into Home Assistant. All appears to be working now.

1 Like

I am trying to get these working with Smartlife in HA, but the HA sees them as a switch rather than a light. So I don’t have dimmer control in HA.
Has anyone has similar issue / is there a trick to make them working?

TYA

I have 2 Gosund dimmer switches that are working fine, they come across in the Tuya integration as lights - bought the a few months ago (they are on firmware V1.03).
Bought another pair last week and the one I just installed only comes across as a switch :confused:
This one shows up differently in the Smart Life UI - even the icon is different - and is on firmware version 1.0.4.

how do you check the FW version in Smartlife?

Click on the switch/dimmer in the app; in the top right corner click on the ‘edit’ pencil, the option at the very bottom says ‘Device Update’ and will show you the firmware version - that’s on my Android phone.

I confirm, mine has the same version

v1.0.4 for both MCU and Main Module

–A

Forgive for this being slightly off-topic but I wanted to confirm that using Tuya app + HA integration, worked for me for a Gosund Led Strip. Thanks to who pointed out the compatibility!

Hi @BO1 - I just noticed another weird behavior of the device that’s on V1.0.4:
It reports a strange IP address in the device information: 107.77.245.43
This is NOT my IP address. Heck, it’s not even from my provider, it’s an AT&T one :confused:

Would you, just to satisfy my curiosity, please check, if your device report an IP address as well that’s different from the real one?

Mine reports the correct IP Address