Gosund SW6 3-way issues

I flashed a Gosund sw6, and configured it according to this:

It works in my 3-way circuit, but in the HA gui, the state of the switch seems to be opposite.

I “fixed” it by changing to this in HA

    payload_on: "OFF"
    payload_off: "ON"

The other issue is when I try to use it in an automation, it doesn’t matter if I call switch.turn_off, or switch.turn_on, it just toggles the switch. I’m trying to have the lights come on when motion is detected, which works, but if the lights are already on, when motion is detected, they turn off, which isn’t ideal.

Is there anything I have configured or wired incorrectly? Any other thoughts on why this switch is behaving this way?

thanks,
Steve

I Followed this to the letter it works. Just did two myself successfully.

If it doesn’t do the job for you, try resetting the module, and start over. If it still doesn’t do the trick, maybe the wiring?

Thanks, good to know someone got one of these working recently. I can certainly try to reset the configuration and try again. I never tried swapping the travelers. I wonder if that would make a difference. I now have a project to work on during our forecast big snow storm.

I’m not sure what the deal is with mine. I did reset the config, and swapped the travelers, but nothing changed.

I have mine ‘working’ with some issues, but so far it’s close. The problem you are having with ‘on’ and ‘off’ are inherent to the rules setup.
“Rule3
If the device is sent an EVENT it will Toggle Power2.
Backlog Rule3 ON event#OFF do power2 2 endon ON event#ON do power2 2 endon; Rule3 1”

Based on that rule ANY EVENT toggles the power. So off or on is a toggle. That is the way the setup was configured so I am just working around it in my automations. Just put in a condition if=on or if=off so you don’t toggle when in the wrong state.

My problem now is sometimes it inverts and shows on when it’s off and vice versa, haven’t figured that out yet.

I have had the issue with the inverting, happened after a power loss (me adding some other switches to my house).

What I did to fix it was put both switches in the off position (on the traveller, followed by the SW6 button to turn the lights off), and than I started toggling the switches within the SW6s Tasmota page, that somehow fixed things. After that HA reported the correct settings. Not sure if this was all coincidental but it worked for me :slight_smile:

I had initially tried that, but then the automation never fired. My ugly workaround was using a light sensor already in the room to tell if the light was off for the condition. I later figured out that “off” is case sensitive, and I for some reason had a capital O.

Thanks!

Yes that seems to have fixed it for me. I found it in this video yesterday at around the 14min mark

Bummer that I may have to mess with it after power outages, but oh well.

Thanks,
Steve