Got 404: Not found. Install home assistant on synology without docker

I’m trying to install home assistant on my old synology NAS DS212j
so far I only get “404: Not found” on localhost:8123

here’s what I did, and hope any can help me out. :slight_smile:
I followed every step on this page
since I cannot use docker, I go through method 2 without any problem
until the last part, I didn’t copy any “configuration.yaml”
but tried to start home assistant with this:
$ sudo /volume1/homeassistant/hass-daemon start

It failed and said permission deny, so I went back to my DSM control panel and set the homeassistant folder’s permission for user “homeassistant” to “read/write”
after this I was able to start with: $ sudo /volume1/homeassistant/hass-daemon start
but could not connect to at all

Then I tried to copy a simple yaml file to the homeassistant folder, then restart homeassistant, then I get the “404: Not found”. (the yaml I have is below).
anyone know what I can do next?
I’m stuck with no clue…@@

my configuration.yaml---------------

name: Home
latitude: 22.5083333
longitude: 120.2416667
elevation: 25
unit_system: metric
time_zone: Asia/Taipei

api_password: 123456789

group: !include groups.yaml
automation: !include automations.yaml

You need to put frontend: into your configuration.yaml file. Without this the frontend component will be disabled.


Thanks @benji87 !!!
It worked after adding the frontend :slight_smile: