Got the VM running but can't access

I got home assist running in a VM. I followed Youtube instructons: and set it up as a Linux64 machine. It starts up, gives me an IP address, but when I put the IP into the browser it can’t find it.

I made another VM following the instructions on a different youtube as an Ubuntu64 machine. It starts up and gives me an IP, but as soon as I enter the IP, it crashes (blue screen).

First setup:

Second setup:

Try these instructions:

Those are basically exactly what I already did. I followed these instructions: Windows - Home Assistant

The only thing i notice that I didn’t do is to activate the virtual machine hypervisor. What is that? I enabled it in the Bios. Is there another step?

Those videos are old (the first one is 2 years old, with a reference to an updated video that was done a year ago, and the second one is 5 years old). Home assistant has changed a lot since those videos were published.

The current instructions should be followed, not basically, but exactly as written.

Did you try all these methods to access HA (and waited for it to start as per the “Note”)?

What error messages are you getting?

1 Like

What is the network type set at for the VMmachine?
Host-only, NAT, Bridged
it should be the latter :wink:

Bridged and promiscuous allow all

1 Like

So I haven’t got that far yet. I can’t get past step 3 after “Startup your virtual machine.” It says I should be able to access it through the IP address, but I can’t. It says “unable to connect” on the webpage. Yes, I have tried the IP, Homeassist,.local, etc.

I didn’t go further because it says I should be able to connect at that point so I never installed the core data, The VM boots up and gives me the HA command line.

I’m not a programmer like most others, so please don’t assume I know what may be common knowledge to others.

From the HA command line, we can check some basic info (Common tasks - Operating System - Home Assistant).

What do you get for the info?

Any clues in the logs?

You also seems to forget to say which type of VM, what Hyper-V, vmware, virtual-box ?

I asume it’s not Hyper-V you are trying to run

Oracle VM Virturalbox 7.0.

Explain Hyper V? I don’t think I am trying to run it, I just want to run home advisor on Windows 10. I did turn on the “virtualization technology” in the BIOS. There are two settings in Windows for “virtual machine platform” and “windows hypervisor platform.” Those are both UNCHECKED.

Before I enabled VT in the BIOS, the VM wouldn’t boot at all. It looks like it boots up just fine, I just can’t access it.

1 Like

I can run those when I get home. Do you want me to run all the ones in “home assistant?” To be clear, should I be able to log in to the IP without installing all the core software?

Am I doing something wrong when I didn’t go far enough?

No, just the ha core info & ha core logs and ha supervisor info & ha supervisor logs


I don’t know. It could be a networking issue, hardware issue, etc.

1 Like

Here are screenshots of the files. The core logs has alot of red script, I assume these are errors. The supervisor logs has a couple as well. Can you make sense of any of it?

And I made a new VM with instructions exactly like the tutorial, except I still don’t understand what this means. " Follow this guide if you already are running a supported virtual machine hypervisor." These were both off, so I turned them on.


This is what I get when I try to connect.

Everything looks like it’s running.

Yes you can un-tick them again, Hyper-V is microsofts VM Platform
And you haven’t configured anything related to Hyper-V

And it has nothing to do with your “error message”


core rebuild

PS: Did you also disable secure boot in Bios ?
And choose EFI in Virtual Box

EFI is definitely checked. I’ll have to check on secure boot, but I have a dog sleeping on me right now :blush::blush:.

Just type in “core rebuild” in the command line?

What would secure boot have to do with it?

yes, in the command line.

Im not familiar with Virtual Box, as i run in VMWare , there are lots of cases ( HAOS on barebone is one ) where HA have problems, and Secure-boot needs to be disable, so was also the recommendation for VM priviosly, both on the Host(Windows in your case), but even in the VM.(in some cases)
A VM simulates hardware, thou it obviously have to communicate with the hardware it’s hosted on, And secure boot is a BIOS feature to secure/avoid boot un-trusted software

Awesomeversion could definitely be “defined” as one such, beside “uncaught exemption” could indicated, failure caused beyond Core an HAOS level

PS: Honestly VMWare is so much more stable than VirtualBox, And i’ve seen lots of peculiar issues in this forum , related to VirtualBox
Also if you have some “bogus/additional” devices connected to some of your USB ports, remove them, if they are not intended for HA (or needed initially) (as they most likely can not be “interpreted” as a legacy-device)


Created a new terminal using VMware and followed the tutorial and it works!! I imagine there is no difference between the virtual machines.


same here…vb kindah sucks….
Little harder to configure/setup but 100% worth it :grin:

1 Like