Graph only available with history integration

I ran into a weird bug this week, or at least I think it is a bug. I disabled the history tab since I literally never use it, but for some reason this also disables all available history graphs in other places. So graphs in lovelace are no longer showing and if you click on an entity for more information, it will not show its history.

From the description it is implied that the history integration only provides the history tab, not history tracking overall, that should come from the recorder. So right now I can only have history by enabling the (frankly unusable) history tab?
Is this intended behaviour?

I believe the statement

It depends on the recorder component for storing the data and uses the same database setting. If any entities are excluded from being recorded, no history will be available for these entities.

Means that History uses the recorder component to store the data. Not that the recorder component tracks history.

THis is true.

Do you have recorder in your configuration? If you remove history and don’t have recorder, everything will be gone. If you want history but not the history tab, configure recorder and remove history.

These are my current (relevant) configuration options:

# Postgresql database
  purge_keep_days: 28 #keep 4 weeks
  db_url: !secret db_connect
      - sensor.yr_symbol
      - sensor.time
      - sensor.date_time

#Enables support for tracking state changes over time.
#   include:
#     domains:
#       - light
#     entities:
#       - binary_sensor.presence_tv
#       - binary_sensor.presence_werkkamer
#       - binary_sensor.presence_woonkamer
#       - binary_sensor.presence_anyone_home
#       - binary_sensor.iemand_in_slaap_slaapkamer
#       - binary_sensor.beide_in_slaap_slaapkamer
#       - binary_sensor.pir_multisesensor
#       - binary_sensor.pir_voordeur
#       - binary_sensor.pir_werkkamer
#       - binary_sensor.pir_woonkamer_deur
#       - binary_sensor.time_bed
#       - binary_sensor.time_evening
#       - binary_sensor.time_workhours

I simply commented out the entire history config part when I ran into this issue. Now that I have re-enabled just the history part (without the include part) everything is working again.

My theory is that somehow the inclusion options of the history tab get mixed with the exclusion options of the recorder tab and when I disabled history. AFAIK just using exclude should include everything else by default normally.