Great stuff in 1.14.0

Thank you @ottowinter and all the contributors.

4 Likes

Thanks for all the contributors and community members!

I mean just look at the top image table - most of the integrations there were by outside contributors this time. It’s great that I can focus more on the core aspects (like captive portal and native api refactoring) now :slight_smile:

7 Likes

Just a word of caution.
I updated to this today and as soon as I flashed my nodemcu, wifi stopped working. Reflashing with Tasmota and it connects immediately again.
This device has worked for weeks with 1.13.6 - it’s just 1.14.0 that has killed it. From the github it seems this is some kind of known issue - but Tasmota works.
Otto did assist on discord but it’s still not working and no solution in sight so I recommend a full snapshot so you can restore to 1.13.6 if you run into a similar problem.

Couple of changes required for xiaomi miflora sensors, but updated all 18 esphome devices via the update all. No issues to report

Thanks @OttoWinter

Otto Winter and many developers …
Congratulation !!!

I always pulling for you. for your sake, I am happy Esphoming…
Thank you.

which devices have prolems? Or all??

How to update to 1.14? Thanks

how did you install esphome?

tried the new “update all” option, but i’ll had to enter one of the options within the compile window


INFO Successfully compiled program.
Found multiple options, please choose one:
  [1] /dev/ttyACM0 (ttyACM0)
  [2] /dev/ttyACM1 (ttyACM1)
  [3] /dev/ttyUSB0 (FT232R USB UART)
  [4] Over The Air (3d_printer.local)

But whatever (4) i pressed within this window, nothing happens :slight_smile: what/ how do i enter this 4th option ?
Running Hassio with the ESP add-on

I only have one device running esphome (rest are Tasmota). It is a nodemcuv3 with a LCD screen (which is why I used esphome)
I just ordered an esp32 to try as I think this is only an issue with the ESP8266 chip.

I had the same issue with “update all”, and I think I resolved it by restarting the addon and trying again. The second time, I didn’t get that menu and it just uploaded automatically as it has in the past. I don’t remember exactly what fixed it, but between doing a clean compile, re-uploading, and restarting the addon, my two 8266 NodeMCUv3 boards are working on 1.14.

How do you upgrade to 1.14 ?

I get this, and see no way to upgrade. Even after switch ‘auto update’ on and restarting HA

Add-on version: 1.13.6
You are running the latest version of this add-on.

I use docker and just pulled the latest:

docker pull esphome/esphome

Hassio addon, now I see the possibility of upgrading the addon, and did it

having the same issue, how to upgrade? i’m running hassio.

Same as you update any addon.