Groups and Views?

Not sure what I’m doing wrong. I have made groups and trying to display them into a view. But every time I and the line of code view: yes it makes the view tab but all the entities show up at the top as badges. I would like to see them in the block format. See part of my config below.

view: yes
- group.Main_Floor
- group.Kitchen
- group.Doors
- group.Weather
- group.Dark_Sky
- group.Media
- group.Outside
name: Main Floor
- climate.thermostat
- light.great_room_level_4_0
- switch.great_room_rec_switch_3_0
- switch.hall_light_switch_2_0
- light.dining_room
- light.kitchen_light_level_5_0
- light.front_outside
- sensor.speedtest_download
- sensor.speedtest_upload
name : Kitchen
- light.dining_room
- light.kitchen_light_level_5_0
name: Doors
- lock.front_door
- cover.garage_door_opener
name: Netatmo
view: yes
- sensor.netatmo_indoor_temperature
name: Dark Sky
- sensor.dark_sky_apparent_temperature
- sensor.dark_sky_daily_summary
- sensor.dark_sky_hourly_summary
- sensor.dark_sky_minutely_summary
- sensor.dark_sky_icon
- camera.ontario_radar

Use preformatted text when posting YAML

When you add a sensor to a view without adding it to a group, it’ll display at the top. So add the sensors to a group, add that group to a view (group with view:yes). Some helpful info here:

This is very interesting. I had views working fine, then did some rework of my GUI and now, I’m in the same situation as you are.

What ever I do with Views…everything shows up as badges, not as Views (or tabs) as I had it before. This is really strange. I followed the guide on “Bruh Automation”. Done exactly what he did but still, badges instead of “tabs”.

I need help solving this.

Post the YAML of your groups configuration.

Using an include from configuration.yaml for this file:

group: !include groups.yaml

First that follows are the group declarations, further down you’ll find the Views. With this exact config… no “tabs” (views) shows up in HA

    name: Källare
      - switch.kallare_hoger_fonster
      - switch.kallare_vanster_fonster
      - switch.test

    name: Mellanplan
      - switch.kok_hornet
      - switch.pianorum_fonster
      - switch.pianorum_bank
      - switch.vardagsrum_fonster
      - media_player.cc_vardagsrum
      - media_player.openelec__kodi
      - light.hue_iris_1

    name: Övervåning
      - switch.sovrum_ah_vanster
      - switch.sovrum_ah_hoger
      - switch.fonster_overvaning_dator
      - switch.overvaning_balkong_fonster
      - media_player.overvaning 
      - light.hue_lightstrip_plus_1
      - light.a_skrivbordslampa

    name: Sensorer
      - sensor.kallare_temperature
      - sensor.kallare_luminance
      - sensor.mellanplan_temperature
      - sensor.mellanplan_luminance
      - sensor.overvaning_temperature
      - sensor.overvaning_luminance 
      - sensor.yr_symbol
      - sun.sun

    name: Hassbian
      - sensor.ram_free
      - sensor.disk_use_home

    name: DS213+
      - sensor.cpu_load_total
      - sensor.memory_usage_real
      - sensor.network_up
      - sensor.status_sda
      - sensor.status_sdb
      - sensor.volume_used_volume_1

    name: Huvudbrytare
      - group.kallare
      - group.mellanplan
      - group.overvaning

# Alarm clock
    name: 'Alarm Clock'
      - sensor.alarm_clock_time
      - input_slider.alarm_clock_hour
      - input_slider.alarm_clock_minute
      - input_boolean.alarm_clock_status

  view: yes
  name: Källare
    - group.kallare

    view: yes
    name: Mellanplan
      - group.mellanplan

    view: yes
    name: Övervåning
      - group.overvaning

    view: yes
    name: Sensorer
      - group.sensorer

    view: yes
    name: System
      - group.all_automations
      - group.all_scripts
      - group.all_switches
      - group.alarm_clock
      - group.DS213+
      - group.Hassbian

Can you give an example of a sensor that’s showing as a badge rather than on a card?

Are you saying that all of the sensors in sensorer are showing as badges?

It’s very weird, i was testing the exact same config 2 days ago… and I had badges for all sensors. Commented out the Views and just re-enabled. Now I have no badges at all. Can’t explain wtf is going on :slight_smile:

But I also don’t have any Views.

Also, trying to change the GUI using the built in tools, from group to View doesn’t work. It keeps loading and loading and loading and never finishes.

Yeah - the first and only time I tried using the config option, it didn’t seem to work for me.

I’m wondering if indentation has anything to do with it. All of the groups in my groups.yaml start on the left - no indentation at all.

My gut feeling is that your indentation should be fine as long as it’s consistent within the file, but maybe not…


Just restarted HA… after a reboot, it looks like this with the VIEWS enabled.

What is interesting to note is that all switches in the “Switches” card are hidden in my customization chapter… how the heck can they be shown… something is colliding or conflicting between groups and views and customizations?

I’m not sure what you mean by “with views enabled”. Do you mean when you uncomment those entries (from #Views and down )

I wonder if making a change by using the config panel caused problems. Have you tried removing the indentation so that everything starts at the left column?

All validated using VS Code while writing the config, also checked with yaml lint 100% ok

And starting in the 1st column? (top-level entries aren’t indented?)

Did the items that were hidden with “customization” reappear at the same time? Was this right after using config: for the first time?

Exactly, with enabled I meant uncommented.
The image you see above when all looks wierd and badges are appearing is when the views are uncommented.

Commented, HA looks normal.

Fixed! Indentation issue and implementation of alarm clock :slight_smile:

Hello guys! It may seem too basic for you guys, but I cant find out how to group these two “cards” into on to be named Cenários! Any helping hand!?!?

Hi Antonio,

Something like this might work:

    - switch.frente
    - switch.fundo
    - switch.meio
    - automation.apresentar
    - automatino.coversar

And if you wanted it on a separate tab instead of/in addition to a single card, just add:

view: yes

Hopefully that helps!

Thanks a lot! Cheers!

1 Like

Hey, how do I activate the configuration for Groups & Views in

1 Like

I was about to ask the same question. I know it was there, but I haven’t had a chance to work on my system for some time (premature newborn and wife in ICU). Now everything is back to normal, I go into my GUI and POOF Groups & Views is missing from the configuration screen.

Am I missing something?

Found it…kind of… Configuration -> Customization

I hate it, wish we still had the “Groups & Views” tab…