Groups not showing up

I am trying to add DarkSky sensor and show them as a Group. I have followed the simple examples. My understanding is that after making changes in configuration.yaml and groups.yaml, the created groups will automatically show up on Home page. However, in my case no such thing happens. Anyone who can help, please. Here are my files.


  customize: !include customize.yaml
  name: Home
  latitude: hidden
  longitude: hidden
  unit_system: metric
  time_zone: Asia/Hong_Kong


# Sensors
  - platform: time_date
      - 'time'
      - 'date'
      - 'date_time'
      - 'time_date'
  - platform: islamic_prayer_times
    calculation_method: karachi
      - fajr
      - dhuhr
      - asr
      - maghrib
      - isha
  - platform: darksky
    api_key: !secret darksky_api
    name: DarkSky
      - temperature
      - cloud_cover
      - humidity
      - pressure
      - temperature_high
      - temperature_low
# Asus router
  host: 192.168.x.x
  username: hidden
  port: hidden
  ssh_key: /config

  - platform: polling
    api_key: !secret Telegram_Api
      - !secret Telegram_Chat_Id
  - name: yinghome
    platform: telegram
    chat_id: !secret Telegram_Chat_Id

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml


  name: DarkSky
    - sensor.darksky_temperature
    - sensor.darksky_humidity
    - sensor.darksky_daytime_high_temperature
    - sensor.darksky_overnight_low_temperature
    - sensor.darksky_pressure
    - sensor.darksky_cloud_coverage
  • Changes to configuration.yaml typically require restarting Home Assistant to take effect.
  • Changes to groups can take effect after clicking Configuration > Server Controls > Reload Groups (or restarting Home Assistant).

in addition to what @123 said above you might also need to add them to your lovelace configuration in different ways depending on how you have it being controlled (auto, yaml or GUI).

With the YAML lovelace you had to set something like this:

# View for ground floor
# ground_floor:
  view: true
  name: BGG
  icon: mdi:home-floor-g
    - group.climate_0_floor
    - group.blinds_0_floor

# View for 1st floor
  view: true
  name: 1e
  icon: mdi:home-floor-1
    - group.climate_1_floor

With the new lovelave you can click the 3 dots in the upper right corner and have an UI interactive creation of the home page. Works brilliant.

But first check if the group is properly shown in the developer tools states.

No, that code is not for lovelace. It’s for the old states UI.

However, you can still use lovelace in yaml mode tho but you need to select that mode in your configuration.

Thanks, @123. Sorry I did not clarify this. What I meant by understood was that after having taken both of the points (restart and reload) done.

If I need to make some changes on the home page, I normally do via three dots and tinker around.

So did you try to tinker around and add that group to a card in lovelace?

If you didn’t it won’t shows up there since you are manually configuring it.

Ok. So I get from here is that I need to manually add the card. So I clicked Entities and then selected group.darksky_group as the entity. Now I think group.darksky_group is having data issue as I get unknown in the data. Guess that will be a new question that why it gives unknown.

I guess I am doing something wrong here. May be it is not Entities that I need to select from the card selection for this to work? The options are below. What I want is to list all weather conditions listed as a group.

In States under Developer tools, it shows unknown as well for the state.

If a group contained ten lights, the group’s state is:

  • on if at least one of the ten light is on
  • off if all ten lights are off

Each group member has something in common, their state is either on or off.

Now compare that to your darksky group. Its members are temperature, humidity, pressure, cloud coverage, etc. Do they have common values for their state? No, each member has a unique numeric value so there’s no way to summarize the entire group’s state as simply being on or off or even 21 or something like that. So the group’s state is unknown.

You’re conflating the word “list” with Home Assistant’s term group. The term group has special meaning in Home Assistant and it’s not to display all the group’s members in the user-interface. A group is a collection of entities and only the group’s state is reported (in the States page and in the UI).

To display several entities as a list, use the entities card and specify each entity.

      - type: entities
        title: Weather Data
        show_header_toggle: false
          - sensor.darksky_temperature
          - sensor.darksky_humidity
          - sensor.darksky_daytime_high_temperature
          - sensor.darksky_overnight_low_temperature
          - sensor.darksky_pressure
          - sensor.darksky_cloud_coverage

Thank you @123 for the explanation. I got your point.