Grove NFC v1.1 (PN532 ) over I2C not detected

Hi,

I am trying to build an NFC reader. I have the Grove NFC v1.1 PN532-based NFC reader
Grove - NFC - Seeed Studio
around a LIlygo T18 esp32 unit. The pinout is here
LilyGO/LILYGO-T-Energy (github.com)

It seems this reader only works over UART or I2C, so I am trying to use it over I2C. I have the following error:

[14:49:00][C][i2c.arduino:052]: I2C Bus:
[14:49:00][C][i2c.arduino:053]:   SDA Pin: GPIO21
[14:49:00][C][i2c.arduino:054]:   SCL Pin: GPIO22
[14:49:00][C][i2c.arduino:055]:   Frequency: 50000 Hz
[14:49:00][C][i2c.arduino:058]:   Recovery: bus successfully recovered
[14:49:00][I][i2c.arduino:068]: Results from i2c bus scan:
[14:49:00][I][i2c.arduino:070]: Found no i2c devices!

I don’t quite know what I am doing with hardware, so here is what I have done:

  • I have cut the NFC unit’s UART jumpers and soldered the I2C ones:
    P1 – I2C
    P2 – SCL
    P3 – SDA

  • I have connected the NFC unit to the following pins:
    * SDA to Pin 21
    * SCL to Pin 22
    * VCC to Pin 3V3 (I have also tried 5V, but no difference)
    * GND to one of the GND pins

This is how I have configured it in esphome (relevant part only – the wifi/ap etc all work and I see the sensors in HA):

i2c:
  sda: 21
  scl: 22
  scan: true
  id: bus_a

pn532_i2c:
  update_interval: 1s
  i2c_id: bus_a
  on_tag:
    then:
    - text_sensor.template.publish:
        id: rfid_tag
        state: !lambda 'return x;'

text_sensor:
  - platform: template
    name: "${device_name_up} NFC Tag"
    id: rfid_tag

Does anyone have any suggestions for what the problem may be?

Hi wigster,

I am having a similar problem with groove NFV 1.1 and ESPHome right now. Have you managed to solve your problem in the meantime? Your post is almost a year old but I don’t see any response.

I’m afraid to say that I gave up on the Grove and bought a different unit made by Elechouse based on the same PN532 chip. I have to say I never figured out why it didn’t work, but the Elechouse one worked out of the box.