Guide: How to learn broadlink RF codes

Ok, found this video on youtube (with pretty much the same steps, but with visualization and some other details) and it was spot on!


If anyone in here is having problems, I think it can help.

@nikd1 - You talk about managing to get the RF codes with the process. But the RM4C Pro is an IR only device and dosn’t do RF! Did you mean IR Codes?

Can ANYONE confirm that they have managed to learn their RF switches with an RM4 Pro (Not an RM2 or RM3 pro+ etc) And use them in Home Assistant. I’ve not seen any proof at all online that people have tbh? Even the video link above uses an older RM pro 3 which IS compatible with the e-control app… The RM4 Pro is not compatible with this app!

Hi I still have the same problem.
If any one have a solution, please send us informations
Thanks a lot.

So i’ve managed to learn RF codes on it through HA - But not send any back out that work so far… There’s a couple of issues raised in Github i’ll be keeping an eye on.

Got RF working on my RM4 Pro FINALLY. Through trial and error.

First step is to learn an RF code in the app and test it works

  1. Create a button in the app
  2. Then hold down on the button
  3. Then click “learn single”
  4. Then click “sweap frequency”
  5. Now hold down the button on your RF remote until it learns the RF frequency.
  6. Next step is click ‘ok’ then briefly tap the button on your RF remote to learn the RF code.

Once you have created a button, test it works. If it works you can move onto the next step.

  1. Load home assistant webpage on your desktop browser
  2. Goto services tab (Hint: under developer n settings)
  3. Find broad link learn service.
    Enter the service data host: xxx.xxx.xxx.xxx
    Where XXX is your broadlink IP address on the local network.
    ( don’t click call service yet ).
  4. Now on your cellphone do the following
  5. Hold down on any existing button in the broadlink app
  6. Click “learn single” in the app
  7. Click “sweap frequency” in the app
  8. Hold down RF button on your remote until it detects the frequency
  9. Click ‘ok’ to proceed, it will now want you to press the RF button again, but don’t do it just yet…
  10. First on your desktop pc click ‘call service’
  11. Now you can briefly tap the RF button on your device.
    =====================
    It works, but you need to create new device before each learn (for example, I created curtains each time)
1 Like

Hi @nick2525: do you confirm what app you used? Mine rm4pro work only with broadlink app (not with e-control).
Now I’m going to try, but first I would like to be sure that I’m doing correct tests.

Thank you

I use IHS, https://play.google.com/store/apps/details?id=cn.com.broadlink.econtrol.plus&hl=en_US&gl=US

Thanks! Unfortunatelly my broadlink can’t connect to IHC.
I’m trying your steps with broadlink app…

I putted wifi id and password on broadlink after reset it.
Exit from app and connect rm4pro to home assistant: It works because had yello led when activate remote.learn command.

I received some code on file broadlink_remote_XXXXXXX_codes… It’s this

    "Cancello1": {
        "Open/Close": [
            "JgD8ACcAAfITBgkAAeMrAAHhLwAB4i4AAeMsAAHkLAAB4y0AAeMtAAHjLQAB4i4AAeIuAAHhLwAB4i4AAeEuAAHiLgAB4i4AAeIuAAHiLgAB4i4AAeIuAAHiLgAB4i4AAeEuAAHjLQAB4i8AAeEuAAHhLwAB4S8AAeIuAAHhLgAB4y0AAeItAAHjLgAB4y0AAeEvAAHiLgAB5RUAAfksAAH1EgAKRw8ACC0SAAHqKQAB5BQABA4NAAIFGwAB9iAAAe8MCBMAA/coAAHqJAAB6SoAAeMrAAHmLAAB5CwAAecmAAHmKwAB4y4AAfAdAAHnLAAB4y0AAeslAAHsDAANBQAAAAAAAAAAAAA=",
            "JgCaABQAAeUtAAHmKgAB4ywAAeQsAAHjMAAB3y4AAeIvAAHhLgAB4S8AAeIuAAHhLwAB4S4AAeIuAAHiLgAB4i4AAeIuAAHiLgAB4i4AAeIuAAHhLgAB4i4AAeQsboth AAHiLgAB4ywAAeQuAAHhLgAB5ioAAeQsAAHmKgAB5ikAAecpAAHlLAAB4hUABhwWDwoACiQnAAHmKwAB4iwADQUAAAAAAAAAAAAAAAA="

But I tried to copy both code after b64: whit or without “”: Nothing happened.

What happens when you try the code. Is there an error in the log. Does the rmpro blink. Does the rmpro work to control the device outside of home assistant?

Hi everybody.
Now I’m going to test.
I tried via script and also via services and manual service call.
When I call learn or send command, on Rm4pro, I have amber led for approx 1 second.

entity_id: remote.broirrf
device: open_dk
command: b64:“JgD8ACcAAfITBgkAAeMrAAHhLwAB4i4AAeMsAAHkLAAB4y0AAeMtAAHjLQAB4i4AAeIuAAHhLwAB4i4AAeEuAAHiLgAB4i4AAeIuAAHiLgAB4i4AAeIuAAHiLgAB4i4AAeEuAAHjLQAB4i8AAeEuAAHhLwAB4S8AAeIuAAHhLgAB4y0AAeItAAHjLgAB4y0AAeEvAAHiLgAB5RUAAfksAAH1EgAKRw8ACC0SAAHqKQAB5BQABA4NAAIFGwAB9iAAAe8MCBMAA/coAAHqJAAB6SoAAeMrAAHmLAAB5CwAAecmAAHmKwAB4y4AAfAdAAHnLAAB4y0AAeslAAHsDAANBQAAAAAAAAAAAAA=”,"JgCaABQAAeUtAAHmKgAB4ywAAeQsAAHjMAAB3y4AAeIvAAHhLgAB4S8AAeIuAAHhLwAB4S4AAeIuAAHiLgAB4i4AAeIuAAHiLgAB4i4AAeIuAAHhLgAB4i4AAeQsAAHiLgAB4ywAAeQuAAHhLgAB5ioAAeQsAAHmKgAB5ikAAecpAAHlLAAB4hUABhwWDwoACiQnAAHmKwAB4iwADQUAAAAAAAAAAAAAAAA=
num_repeats: 1
delay_secs: 1
hold_secs: 1

  • press: call services
    I Had amber led ON for 1 second on rm4pro

  • I Setted config.yaml
    logger:
    default: info
    logs:
    homeassistant.components.modbus: warn
    pymodbus.client: warn

  • I have no message on logs (only messages “Config entry for ipp not ready yet. Retrying in 5 seconds” becuase my printer is off)

Regarding last question: I tried to setup broadlink via app Broadlink and all work. Rf code to open external gate in 433mhz, and also IR command to control TV or Climate or HiFi. With HA is going to work only IR section. No RF.

Thanks a lot

If the rmpro can control the gate via the app correctly and the amber light blinks when you send RF code via home assistant, then my guess is the RF code is incorrect. Relearn the code a few times you will see each time the code is slightly different. Focus on tap the RF button on remote very briefly when learning.

Today it’s impossible to learn anything.
I had setted log to debug. I gave that message into log history

-Logger: homeassistant.components.broadlink.remote
-Source: components/broadlink/remote.py:299
-Integration: Broadlink (documentation, [issues]-(https://github.com/home-assistant/home-assistant/issues?-q=is%3Aissue+is%3Aopen+label%3A"integration%3A+broadlink"))
-First occurred: 23:03:23 (1 occurrences)
-Last logged: 23:03:23

-Failed to learn ‘Open’: No code received

Whit short press…
Whit long press, nothing changed…
I’m going to sleep… One clear night = one clear day after…
Thank you

How? I have been messing with it for days and no RF for my RM4 Pro in Home Assistant.

Hey Jonathan - How far have you got with it? Can you detail the process you’ve taken? Are you using the RM4 Pro or a different model? What app are you using on your phone to setup the RM pro?

Hi Oliver, thanks for the response!

So I have been down a few different paths. No matter what, whenever I try to get the RM4 Pro into RF mode it gets locked out of HA (Real bitch move of broadlink imho lol). I ended up flashing a Sonoff RF Bridge with Tasmota/Portisch and grabbing the RF codes of my remotes from there. So where I am now is I have the RF codes I would like my RM4 Pro to send from Home Assistant to control my roller shades but have not had any success yet.

Here is the switch I created in configuration.yaml

switch:
  - platform: broadlink
    host: 192.168.1.103
    mac: '24:DF:A7:D3:20:66'
    switches:
      shade_up:
        friendly_name: "Up"
        command_on: "AAB037050809A606540140028012F2C092B2A3B2A3B2B2B2A3B2A3A3A3B2A3A3B2B2A3A3A3A3A3B2B2B2A3A3A3A3A3A3A3B2A3A3B2B2B2A3A3B255"
        command_off: "AAB037050809A606540140028012F2C092B2A3B2A3B2B2B2A3B2A3A3A3B2A3A3B2B2A3A3A3A3A3B2B2B2A3A3A3A3A3A3A3B2A3A3B2B2B2A3A3B255"
      shade_down:
        friendly_name: "Down"
        command_on: "AAB037050809B00640015402761270C092B2A3B2A3B2B2B2A3B2A3A3A3B2A3A3B2B2A3A3A3B2A3A3A3B2A3A3A3A3A3A3A3B2A3A3B2A3B2B2B2B255"
        command_off: "AAB037050809B00640015402761270C092B2A3B2A3B2B2B2A3B2A3A3A3B2A3A3B2B2A3A3A3B2A3A3A3B2A3A3A3A3A3A3A3B2A3A3B2A3B2B2B2B255"
      shade_stop:
        friendly_name: "Stop"
        command_on: "AAB037050809A606540140028012F2C092B2A3B2A3B2B2B2A3B2A3A3A3B2A3A3B2B2A3A3A3B2A3B2A3B2A3A3A3A3A3A3A3B2A3A3B2A3B2A3B2B255"
        command_off: "AAB037050809A606540140028012F2C092B2A3B2A3B2B2B2A3B2A3A3A3B2A3A3B2B2A3A3A3B2A3B2A3B2A3A3A3A3A3A3A3B2A3A3B2A3B2A3B2B255"

Got ya. So i’m assuming your using the broadlink manager android app to do the initial setup of the RM4 pro?
(You can’t really be using the e-control/IHC apps unlikely as they dont work with the RM4 model) Is that correct?

I am using the broadlink manager ios app to add the RM4 Pro to wifi. I stop as soon as wifi is connected and the integration shows up in Home Assistant. I have the integration showing up in home assistant.